POJ 2387 Til the Cows Come Home

Description:

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input:

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output:

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input:

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output:

90

Hint:

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.
 
题意:有n个点,m条边,现在问奶牛从第n个点到第一个点的最短路径是多少,也就是1~n的最短路径,(毕竟路是双向的,这里发现,POJ好喜欢奶牛的啊~~),直接套用模板中的任何一个就行了。
#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;

const int N=1010;
const int INF=0x3f3f3f3f;

int G[N][N], dist[N], vis[N], n;

void Init()
{
    int i, j;

    for (i = 1; i <= n; i++)
    {
        dist[i] = INF;
        vis[i] = 0;
        for (j = 1; j <= n; j++)
            G[i][j] = INF;
        G[i][i] = 0;
    }
}

void Spfa(int u)
{
    int i, v;
    queue<int>Q;

    Q.push(u);
    dist[u] = 0;

    while (!Q.empty())
    {
        v = Q.front(); Q.pop();

        for (i = 1; i <= n; i++)
        {
            if (dist[i] > dist[v] + G[v][i])
            {
                dist[i] = dist[v]+G[v][i];

                if (!vis[i])
                {
                    Q.push(i);
                    vis[i] = 1;
                }
            }
        }

        vis[v] = 0;
    }
}

int main ()
{
    int m, a, b, c;

    while (scanf("%d%d", &m, &n) != EOF)
    {
        Init();

        while (m--)
        {
            scanf("%d%d%d", &a, &b, &c);

            G[a][b] = min(G[a][b], c);
            G[b][a] = G[a][b];
        }

        Spfa(1);

        printf("%d\n", dist[n]);
    }

    return 0;
}
posted @ 2015-09-16 10:30  搁浅の记忆  阅读(117)  评论(0编辑  收藏  举报