HDU 1003 Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4
Case 2: 7 1 6

 

和最大的最长子序列:
#include<stdio.h>
int main ()
{
    int T, i, n, x, a, b, c, sum, M, k = 0, flag = 0;
    scanf("%d", &T);
    while (T--)
    {
        k++;
        scanf("%d %d", &n, &x);
        sum = M = x;
        a = b = c = 1;
        for (i = 2; i <= n; i++)
        {
            scanf("%d", &x);
            if (sum + x < x)
            {
                sum = x;
                a = i;
            } //若sum+x比x小,则将sum置为x,暂将此时的位置记录下来
            else
                sum += x; //否则直接加上
            if (sum > M)
            {
                M = sum;
                b = a;
                c = i;
            } //当找到更大子序列的和时更改最大值和对应位置
        }
        if (flag == 1)
            printf("\n");
        printf("Case %d:\n", k);
        printf("%d %d %d\n", M, b, c);
        flag = 1;
    }
    return 0;
}
 
posted @ 2015-04-24 11:07  搁浅の记忆  阅读(114)  评论(0编辑  收藏  举报