Hdu_1016Prime Ring Problem

这题目我做的时候有个大坑..................气死我了.......一个int n的定义

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21195    Accepted Submission(s): 9480


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

 

Sample Input
6 8
 

 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

 

Source
# include<iostream>
# include<cstdio>
# include<cstring>
using namespace std;
int vis[30],buff[30],ans,n,flag;
bool prime(int x,int y)
{
    int sum=x+y;
    for(int i=2;i*i<=sum;i++)
    {
        if(sum%i==0)
            return 0;
    }
    return 1;
}
void dfs(int cur)
{
    vis[1]=1;
    if(cur>n && prime(buff[1],buff[n]))
    {

        if(!flag)
        {
            printf("Case %d:\n",ans);
            flag=1;
        }
        for(int i=1;i<n;i++)
        {
            printf("%d ",buff[i]);
        }
        printf("%d\n",buff[n]);

    }
    else
    {
        for(int i=2;i<=n;i++)
        {
            buff[cur]=i;
            if(!vis[i] && prime(buff[cur-1],buff[cur]))
            {
                vis[i]=1;
                dfs(cur+1);
                vis[i]=0;
            }
        }
    }
}
int main()
{
    //int n;//手贱的给这定义里一个int n;
    ans = 0;
    while(scanf("%d",&n)!=EOF)
    {
        ans++;
        flag = 0;
        memset(vis,0,sizeof(vis));
        buff[1] = 1;
        dfs(2);
        printf("\n");
    }
    return 0;
}
View Code

 

posted @ 2013-10-03 21:52  天天AC  阅读(238)  评论(0编辑  收藏  举报