第十二周作业
😀挺开心的一周
这个作业’属于那个课程 | C语言程序设计ll |
这个作业‘要求在哪里 | 博客园第十二周作业 |
我在这个课程的目标是 | 理清思路,辨别函数指针与指针函数 |
这个作业在那个具体方面帮助我实现目标 | 巩固知识,做题目 |
参考文献 | 小甲鱼视频 |
题目6-1 计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
1.完整代码
#include <stdio.h>
#include <string.h> //字符串处理
#include <stdlib.h> //标准库函数头文件,定义杂项函数及内存分配函数
#define MAXN 10 //宏定义
#define MAXS 20
int max_len( char *s[], int n ); //函数声明
int main()
{
int i, n;
char *string[MAXN] = {NULL}; //判断动态分配是否成功
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS); //给string[i]分配20个char指针单元,返回char指针
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n)); //调用函数
return 0;
}
int max_len( char *s[], int n ) //函数的定义
{
int max_len = 0;
int i = 0;
for(i = 0; i < n; i++){
int len = strlen(s[i]); //计算字符串长度
if(len > max_len){
max_len = len;
}
}
return max_len;
}
2.设计思路:
流程图:
3.本题调试中遇到的问题及解决办法
问题:本题没有遇到什么问题,因为这个作业实际上在之前就已经做过这种题目了,直接运用strlen()函数就可以得到字符串长度。
4.运行截图
题目:6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
#
输出样例:
3
1.完整代码
#include <stdio.h>
#include <stdlib.h> //标准库函数头文件,定义杂项函数及内存分配函数
#include <string.h> //字符串处理
struct ListNode { //结构体的定义
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head ); //函数声明
int main()
{
struct ListNode *head; //定义结构指针
head = createlist();
printf("%d\n", countcs(head)); //调用函数
return 0;
}
/* 你的代码将被嵌在这里 */
int countcs( struct ListNode *head ) //函数的定义
{
int len = 0;
while(head)
{
if((*head).code[1] == '0' && (*head).code[2] == '2')
{
len++;
} //判断是否为计算机专业的学生
head = (*head).next;
}
return len;
}
2.设计思路:
流程图:
3.本题调试中遇到的问题及
解决办法
问题:出现了编译错误,因为我开始用的是“.”,后来去搜了一下它与“->”的区别。开始是因为漏掉了一个括号,将 "(head).code[]" 写成了 "head.code[]".
解决方法:可以看一下关于"."与"->"的区别的博客。
4.运行截图
题目:6-3 删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
1.完整代码
#include <stdio.h>
#include <stdlib.h> ////标准库函数头文件,定义杂项函数及内存分配函数
struct ListNode { //结构体的定义
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head ) //函数的定义
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
struct ListNode *createlist()
{
struct ListNode *head, *p1, *tail;
int num;
head=(struct ListNode *)malloc(sizeof(struct ListNode));
p1=tail=(struct ListNode *)malloc(sizeof(struct ListNode));
p1->next=tail->next=head->next=NULL;
while(1)
{
scanf("%d",&num);
if(num!=-1)
{
p1->data=num;
if(head->next==NULL)
{
head->next=p1;
}
else
{
tail->next=p1;
tail=p1;
}
p1=(struct ListNode *)malloc(sizeof(struct ListNode));
p1->next=NULL;
}
else
break;
}
return head;
}
struct ListNode *deleteeven(struct ListNode *head)
{
struct ListNode *num,*p;
p=head;
num=head->next;
while(num!=NULL)
{
if(num->data%2==0)
{
p->next=num->next;
}
else
p=p->next;
num=num->next;
}
return head->next;
}
2.设计思路:
流程图:
3.本题调试中遇到的问题及解决办法
参考大佬代码,看的迷迷糊糊的。
4.运行截图
预习作业
从第十三周开始,将进入课程设计阶段,请在本次作业中给出:
1.所在小组想要开发的项目的名称和目标;
2.项目主体功能的描述;
3.现阶段已做的准备工作;
4.小组成员名单和进度安排。(课程设计阶段:13-17周
1.所在小组想要开发的项目的名称和目标
开发的项目名称:贪吃蛇
目标:能清楚的把贪吃蛇这个游戏搞出来
2.项目主体功能的描述
首先先构造出小蛇,让小蛇移动,然后让玩家控制小蛇移动,让系统判断游戏失败,最后让小蛇吃食物增加长度。
3.现阶段已做的准备工作
初步定了游戏开发项目,然后了解游戏内容,打算继续看书,深入了解游戏并开发
4.小组成员名单和进度安排。(课程设计阶段:13-17周)
小组成员:熊亚婷,章满,张英杰
进度安排:初步定了游戏,后期小组将继续讨论游戏,完成游戏的后期操作
二,学习进度条
时间 | 代码行数 | 这周所花的时间 | 学到的知识点简介 | 目前比较疑惑的问题 | |
---|---|---|---|---|---|
第一周 | 2/28-3/2 | 51 | 两天 | 数组的运用 | 无 |
第二周 | 3/5-3/10 | 98 | 零零碎碎的三天 | 一维数组的用法和编写程序处理文件 | 数组长度是否为变量和文件结构与类型 |
第三周 | 3/11-3/17 | 92 | 零零碎碎的一天 | 二维数组的运用以及子数组 | 运用else语句与else if区别 |
第四周 | 3/20-3/22 | 119 | 十六个小时 | 选择排序法以及冒泡排序法 | if语句多分支结构 |
第五周 | 3/26-3/28 | 63 | 十个小时 | 字符串与字符的区别对待以及strcpy语句用法 | 如何看到题目就知道要用二维数组 |
第六周 | 4/1-4/4 | 109 | 四天 | 指针与数组 | 分不清*与&的意义,不会用指针 |
第七周 | 4/8-4/12 | 114 | 五天 | 指针与数组 | 容易用着用着就分不清指针怎么用 |
第八周 | 4/15-4/19 | 162 | 两天 | 动态内存分配 | 对动态内存分配还是迷迷糊糊的 |
第九周 | 4/24-4/26 | 109 | 两天 | 简单的运用结构写题 | 结构指针是如何作为函数的参数的 |
第十周 | 4/30-4/30 | 0 | 一天 | 巩固结构体知识 | 理解能力比较差 |
第十一周 | 5/9-5/10 | 29 | 两天 | 递归函数,static | 说不上疑惑什么,但是不会写这次作业 |
第十二周 | 5/14-5/15 | 158 | 一天 | 指针函数与函数指针的区别 | 虽然感觉理解二级指针,但是不会用 |
折线图:
时间 | 累计代码行数 | 累计博客字数’ |
---|---|---|
第一周 | 51 | 1144 |
第二周 | 43 | 2009 |
第三周 | 92 | 2968 |
第四周 | 119 | 4566 |
第五周 | 63 | 5976 |
第六周 | 109 | 8545 |
第七周 | 114 | 11321 |
第八周 | 162 | 14248 |
第九周 | 109 | 17031 |
第十周 | 0 | 19832 |
第十一周 | 29 | 23260 |
第十二周 | 158 | 26340 |
三,学习感悟
本周学习了指针进阶,讲述了指针数组与数组指针区别,以及函数指针与指针函数的区别,二级指针;对于指针数组与数组指针上个星期也做了预习,所以在讲述的时候不会觉得很难理解,但是对于指向指针的指针,也就是二级指针,感觉有些迷迷糊糊,大概意思理解,但是真的使用的时候有感觉有些分不清,也是通过了上课才知道二维数组与二级指针的知识联系,但是还是会按照之前的思维去做题目。
最后去学习了一下下节课要学习的链表
运用链表的优点:
相比较普通的线性结构,链表结构的可以总结一下:
(1)单个结点创建非常方便,普通的线性内存通常在创建的时候就需要设定数据的大小
(2)结点的删除非常方便,不需要像线性结构那样移动剩下的数据
(3)结点的访问方便,可以通过循环或者递归的方法访问到任意数据,但是平均的访问效率低于线性表
四,结对编程感悟:
我们会自行的在教室去学习,讨论题目,但是本周第三题看了一下还是两个人都不太明白,我们还走在努力能够理解它们的路上。
所以可能第三题的流程图画的不太正确,因为是参考大佬的代码,但我们也没看明白,思路有些混乱。