poj 1163 The Triangle 记忆化搜索

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 44998   Accepted: 27175

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

 

#include<iostream>
#include<stdio.h>
using namespace std;
int n;
int ma[105][105];
int dp[105][105];
int dfs(int row,int col){
    if(row>n) return 0;
    if(dp[row][col]) return dp[row][col];
    dp[row][col]=ma[row][col]+max(dfs(row+1,col),dfs(row+1,col+1));
    return dp[row][col];
}
int main(){

    while(~scanf("%d",&n)){
        for(int i=0;i<=n+2;i++)
          for(int j=0;j<=n+2;j++)
            dp[i][j]=0;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=i;j++){
                scanf("%d",&ma[i][j]);
            }
        }
        printf("%d\n",dfs(1,1));
    }
}
View Code

 

posted @ 2016-07-27 10:14  超级学渣渣  阅读(254)  评论(0编辑  收藏  举报