poj 1115 Lifting the Stone 计算多边形的中心

Lifting the Stone
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 
 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 
 

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 
 

Sample Input

2 4 5 0 0 5 -5 0 0 -5 4 1 1 11 1 11 11 1 11
 

Sample Output

0.00 0.00 6.00 6.00
 
 
就是简单求多边形的重心问题,数学问题。
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        double x0,y0,x1,y1,x2,y2;
        double s=0.0,sx=0.0,sy=0.0,area;
        scanf("%lf%lf%lf%lf",&x0,&y0,&x1,&y1);
        for(int i=0;i<n-2;i++)
        {
            scanf("%lf%lf",&x2,&y2);
            area=(x1-x0)*(y2-y0)-(x2-x0)*(y1-y0);
            sx+=area*(x0+x1+x2);
            sy+=area*(y0+y1+y2);
            s+=area;
            x1=x2;
            y1=y2;
           // cout<<"dd"<<area<<endl;

        }
        //cout<<s<<endl;
        printf("%.2lf %.2lf\n",sx/s/3,sy/s/3);
    }
    return 0;
}
View Code

 

附加两篇大神的博客,第一个是详细解释了poj1185 的算法,清晰明了
第二篇说的是求多边形重心的其他情况。
http://www.cnblogs.com/jbelial/archive/2011/08/08/2131165.html
 
 
http://www.cnblogs.com/bo-tao/archive/2011/08/16/2141395.html
posted @ 2016-03-30 11:55  超级学渣渣  阅读(276)  评论(0编辑  收藏  举报