A - Oulipo

A - Oulipo

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

InputThe first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
OutputFor every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题目描述:

求在字符串s中,有多少个字符串p。

分析:

KMP题,因为在已经匹配的字符串末尾,仍可以作为下一个匹配的字符串的开头。

而next数组正是记录前后缀相同的最长长度。

主要是改变k使它继承与前缀相同的后缀。

if(k==plen-1) 
{
    ans++,k=plen-1;
}

 

代码:

 

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<sstream>
#include<vector>
#include<stack>
#include<deque>
#include<cmath>
#include<map>
#define lson i<<1,l,mid
#define rson i<<1|1,mid+1,r
using namespace std;
typedef long long ll;
const int maxn=1e6+6;
const int INF=1e9;
int _next[maxn];
char ptr[maxn],str[maxn];
void calnext(int len)
{
    _next[0]=-1;
    int k=-1;
    for(int i=1;i<len;i++)
    {
        while(k>-1&&ptr[k+1]!=ptr[i]) k=_next[k];
        if(ptr[k+1]==ptr[i]) k++;
        _next[i]=k;
    }
}
int kmp(int plen,int slen)
{
    calnext(plen);
    int ans=0;
    int k=-1;
    for(int i=0;i<slen;i++)
    {
        while(k>-1&&ptr[k+1]!=str[i]) k=_next[k];
        if(ptr[k+1]==str[i]) k++;
        if(k==plen-1) 
        {
            ans++,k=plen-1;
        }
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",ptr,str);
        int plen=strlen(ptr),slen=strlen(str);
        int ans=0;
        if(plen==1)
        {
            for(int i=0;i<slen;i++)
            {
                if(ptr[0]==str[i]) ans++;
            }
        }
        else
        {
            ans=kmp(plen,slen);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

posted on 2020-03-29 23:23  Aminers  阅读(207)  评论(0编辑  收藏  举报

导航