题目1 : Farthest Point

时间限制:5000ms
单点时限:1000ms
内存限制:256MB

描述

Given a circle on a two-dimentional plane.

Output the integral point in or on the boundary of the circle which has the largest distance from the center.

输入

One line with three floats which are all accurate to three decimal places, indicating the coordinates of the center x, y and the radius r.

For 80% of the data: |x|,|y|<=1000, 1<=r<=1000

For 100% of the data: |x|,|y|<=100000, 1<=r<=100000

输出

One line with two integers separated by one space, indicating the answer.

If there are multiple answers, print the one with the largest x-coordinate.

If there are still multiple answers, print the one with the largest y-coordinate.

 

样例输入
1.000 1.000 5.000
样例输出
6 1
复制代码
// Java版本
import java.util.Scanner;

public class Main {
/*

2
0 0
0 3

1.000 1.000 5.000

 */

    public static void main(String[] args) {
        
        Scanner scanner = new Scanner(System.in);
        double x,y,r;
        x=scanner.nextDouble();
        y=scanner.nextDouble();
        r=scanner.nextDouble();
        
        int ll=(int) (x-r);
        int lr=(int)(x+r);
        int iya,iyb;
        double max=-1;
        double tmp;
        double r2=r*r;
        double result;
        int maxx=(int) x,maxy=(int) y;
        for(int ix=ll; ix<=lr; ++ix){
            //计算对应的iy
            tmp=Math.sqrt(r2-(ix-x)*(ix-x));
            iya=(int) (tmp+y)-1;
            iyb=(int) (y-tmp)-1;
            //System.out.println(iya+"  "+ iyb);
            result =( iyb-y)*( iyb-y)+(ix-x)*(ix-x);
            if(Double.compare(Math.sqrt(result), r)<=0&&Double.compare(result, max)>=0){ //大于等于
                max=result;
                maxx=ix;
                maxy=iyb;
            }
            
            iyb++;
            result =( iyb-y)*( iyb-y)+(ix-x)*(ix-x);
            if(Double.compare(Math.sqrt(result), r)<=0&&Double.compare(result, max)>=0){ //大于等于
                max=result;
                maxx=ix;
                maxy=iyb;
            }

            iyb++;
            result =( iyb-y)*( iyb-y)+(ix-x)*(ix-x);
            if(Double.compare(Math.sqrt(result), r)<=0&&Double.compare(result, max)>=0){ //大于等于
                max=result;
                maxx=ix;
                maxy=iyb;
            }

            result =( iya-y)*( iya-y)+(ix-x)*(ix-x);
            if(Double.compare(Math.sqrt(result), r)<=0&&Double.compare(result, max)>=0){ //大于等于
                max=result;
                maxx=ix;
                maxy=iya;
            }
            iya++;
            result =( iya-y)*( iya-y)+(ix-x)*(ix-x);
            
            if(Double.compare(Math.sqrt(result), r)<=0&&Double.compare(result, max)>=0){ //大于等于
                max=result;
                maxx=ix;
                maxy=iya;
            }
            
            iya++;
            result =( iya-y)*( iya-y)+(ix-x)*(ix-x);
            if(Double.compare(Math.sqrt(result), r)<=0&& Double.compare(result, max)>=0){ //大于等于
                max=result;
                maxx=ix;
                maxy=iya;
            }
        }
        
        System.out.println(maxx+" "+maxy);
        scanner.close();
    }
    
   public static void main2(String[] args) {
        
        Scanner scanner = new Scanner(System.in);
        double x,y,r;
        x=scanner.nextDouble();
        y=scanner.nextDouble();
        r=scanner.nextDouble();
        
        int ll=(int) (x-r);
        int lr=(int)(x+r);
        int ya=(int) (y+r);
        int yb=(int) (y-r);
        double max=-1;
        double tmp;
        double result;
        double r2=r*r;
        int maxx=(int) x,maxy=(int) y;
        for(int ix=ll; ix<=lr; ++ix){
            //计算对应的iy
            
            
            for( int iy=yb; iy<=ya; ++iy){
                result =( iy-y)*( iy-y)+(ix-x)*(ix-x);
                if(Double.compare(result, r2)<=0){ //如果在里面
                    if(Double.compare(result, max)>=0){
                        max=result;
                        maxx=ix;
                        maxy=iy;
                    }
                }
            }
        }
        
        System.out.println(maxx+" "+maxy);
        scanner.close();
    }
}
复制代码

 

 

 
posted @   stonehat  阅读(328)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· .NET周刊【3月第1期 2025-03-02】
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
点击右上角即可分享
微信分享提示