PAT 19年秋 7-1 Forever (20分)

7-1 Forever (20分)

"Forever number" is a positive integer A with K digits, satisfying the following constrains:

  • the sum of all the digits of A is m;
  • the sum of all the digits of A+1 is n; and
  • the greatest common divisor of m and n is a prime number which is greater than 2.

Now you are supposed to find these forever numbers.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:

For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

“永远的数字”是一个K位的整数A,满足如下条件

  • A的各位数字的总和为m
  • A+1的各位数字总和为n
  • m和n的最大公因数是大于2的素数

这题考察的是递归+剪枝,之前挺疑惑啥是dfs的,其实过阵子回过头来看,🤠Nice)

#include <iostream>
#include <cstdio>
#include <vector>
#include <cmath>
#include <string>
#include <algorithm>

using namespace std;

bool isPrime(int x) {
    if (x <= 1) return false;
    for (int i = 2, sqr = sqrt(x); i <= sqr; ++i) {
        if (x % i == 0) return false;
    }
    return true;
}

int gcd(int a, int b) {
    if (b == 0) return a;
    else return gcd(b, a % b);
}

int digitSum(int x) {
    int sum = 0;

    string s = to_string(x);
    for (int i = 0, len = s.length(); i < len; ++i)
        sum += s[i] - '0';

    return sum;
}

struct record {
    int sum, val;

    record(int v, int n) : val(v), sum(n) {}

    bool operator<(record &x) {
        if (sum != x.sum) return sum < x.sum;
        else return val < x.val;
    }
};

vector<record> r;

void dfs(int sum, int val, int left, int target) {
    if (left == 0 && sum == target) {
        int n = digitSum(val + 1), g = gcd(sum, n);
        if (g > 2 && isPrime(g)) r.push_back(record(val, n));
    } else if (left > 0)
        for (int i = 0; i <= 9; ++i)
            if (sum + i + left * 9 - 9 >= target && sum + i <= target)
                dfs(sum + i, val * 10 + i, left - 1, target);
}

int main() {
//    freopen("in.txt", "r", stdin);
//    freopen("out.txt", "w", stdout);

    int n, k, m;
    cin >> n;
    for (int i = 1; i <= n; ++i) {
        r.clear();
        cin >> k >> m;
        cout << "Case " << i << "\n";
        for (int j = 1; j <= 9; ++j) dfs(j, j, k - 1, m);
        if (r.empty()) cout << "No Solution\n";
        else {
            sort(r.begin(), r.end());
            for (int j = 0; j < r.size(); ++j)
                cout << r[j].sum << " " << r[j].val << "\n";
        }
    }
}
posted @ 2020-06-16 03:05  SteveYu  阅读(440)  评论(0编辑  收藏  举报