1154 Vertex Coloring (25分)

A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 1), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
 

Sample Output:

4-coloring
No
6-coloring
No

图着色问题,我们已知图,如果每相邻两个节点都着色不一样,则打印一共有多少种颜色,否则打印No

#include <iostream>
#include <vector>
#include <map>
using namespace std;
int N, M, K;
int main() {
    scanf("%d%d", &N, &M);
    vector<pair<int, int>> v(M);
    for(int i = 0; i < M; i++) 
        scanf("%d%d", &v[i].first, &v[i].second);
    scanf("%d", &K);
    vector<int> color(N);
    while(K--) {
        map<int, bool> m;
        for(int i = 0; i < N; i++) {
            scanf("%d", &color[i]);
            m[color[i]] = true;
        }
        bool isRight = true;
        for(int i = 0; i < M; i++) {
            if(color[v[i].first] == color[v[i].second]) {
                isRight = false;
                break;
            }
        }
        if(isRight) printf("%lu-coloring\n", m.size());
        else printf("No\n");
    }
    return 0;
}

 

posted @ 2020-05-02 13:57  SteveYu  阅读(133)  评论(0编辑  收藏  举报