PAT Advanced 1094 The Largest Generation (25分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]
 

where ID is a two-digit number representing a family member, K (>) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
 

Sample Output:

9 4

给定总共节点数量,给定父节点的数量

给定父节点,给定孩子节点

然后我们要求最大层级数量。

求解方式:我们使用一次dfs,进行放进node,之后进行一次遍历,将每层的元素映射进map,

最后我们求出map中最大的key和value,并打印即可

#include <iostream>
#include <map>
#include <vector>
using namespace std;
int M, N;
struct node {
    int id, level = -1;
    vector<int> child;
};
vector<node> v;
map<int, int> m;
void dfs(int index, int level){
    v[index].level = level;
    for(int i = 0; i < v[index].child.size(); i++)
        dfs(v[index].child[i], level + 1);
}
int main() {
    int num, tmp_i;
    scanf("%d%d", &M, &N);
    v.resize(M + 10);
    for(int i = 0; i < N; i++) {
        node tmp;
        scanf("%d%d", &tmp.id, &num);
        while(num--) {
            scanf("%d", &tmp_i);
            tmp.child.push_back(tmp_i);
        }
        v[tmp.id] = tmp;
    }
    dfs(1, 1);
    for(int i = 1; i < M + 10; i++)
        if(v[i].level != -1)
            m[v[i].level]++;
    int max_key = -1, max_val = -1;
    for(auto it = m.begin(); it != m.end(); it++)
        if(it->second > max_val) {
            max_key = it->first;
            max_val = it->second;
        }
    printf("%d %d", max_val, max_key);
    system("pause");
    return 0;
}

 

posted @ 2020-02-01 19:32  SteveYu  阅读(139)  评论(0编辑  收藏  举报