HDU 6153 A Secret(扩展kmp)

A Secret

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 256000/256000 K (Java/Others)
Total Submission(s): 1530    Accepted Submission(s): 570

Problem Description
Today is the birthday of SF,so VS gives two strings S1,S2 to SF as a present,which have a big secret.SF is interested in this secret and ask VS how to get it.There are the things that VS tell:
  Suffix(S2,i) = S2[i...len].Ni is the times that Suffix(S2,i) occurs in S1 and Li is the length of Suffix(S2,i).Then the secret is the sum of the product of Ni and Li.
  Now SF wants you to help him find the secret.The answer may be very large, so the answer should mod 1000000007.

 

Input
Input contains multiple cases.
  The first line contains an integer T,the number of cases.Then following T cases.
  Each test case contains two lines.The first line contains a string S1.The second line contains a string S2.
  1<=T<=10.1<=|S1|,|S2|<=1e6.S1 and S2 only consist of lowercase ,uppercase letter.
 
Output
For each test case,output a single line containing a integer,the answer of test case.
  The answer may be very large, so the answer should mod 1e9+7.
 
Sample Input
2
aaaaa
aa
abababab
aba

 

Sample Output
13
19
 
Hint
case 2:
Suffix(S2,1) = "aba",
Suffix(S2,2) = "ba",
Suffix(S2,3) = "a".
N1 = 3,
N2 = 3,
N3 = 4.
L1 = 3,
L2 = 2,
L3 = 1.
ans = (3*3+3*2+4*1)%1000000007.
 
Source
Recommend
liuyiding   |   We have carefully selected several similar problems for you:  6160 6159 6158 6157 6156 
 
 
题目大意:
给你两个字符串A,B,现在要你求B串的后缀在A串中出现的次数和后缀长度的乘积和为多少。
题解:
扩展KMP模板题,将s和t串都逆序以后就变成了求前缀的问题了,扩展KMP求处从i位置开始的最长公共前缀存于数组,最后通过将数组的值不为0的进行一个等差数列和的和就可以了。
#include<bits/stdc++.h>
using namespace std;
const int mod=1e9+7;
const int N = 1000005;
int Next[N];
long long ex[N]; //即extand[]
char p[N],t[N];
int T;
long long ans;
void pre()   // next[i]: 以第i位置开始的子串 与 T的公共前缀
{
    int lp=strlen(p);
    Next[0]=lp;
    int j=0,k=1;
    while(j+1<lp && p[j]==p[j+1]) j++;
    Next[1]=j;
    for(int i=2; i<lp; i++)
    {
        int P=Next[k]+k-1;
        int L=Next[i-k];
        if(i+L<P+1) Next[i]=L;
        else
        {
            j=max(0,P-i+1);
            while(i+j<lp && p[i+j]==p[j]) j++;  // 枚举(p+1,length) 与(p-k+1,length) 区间比较
            Next[i]=j;
            k=i;
        }
    }
}
void exkmp()
{
    int lp=strlen(p),lt=strlen(t);
    pre();  //next数组初始化
    int j=0,k=0;
    while(j<lt && j<lp && p[j]==t[j]) j++;
    ex[0]=j;
    for(int i=1;i<lt;i++)
    {
        int P=ex[k]+k-1;
        int L=Next[i-k];
        if(i+L<P+1) ex[i]=L;
        else
        {
            j=max(0,P-i+1);
            while(i+j<lt && j<lp && t[i+j]==p[j]) j++;
            ex[i]=j;
            k=i;
        }
    }
}
int main()
{

    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",&t,&p);
        int lt=strlen(t);
        int lp=strlen(p);
        reverse(p,p+lp);
        reverse(t,t+lt);
        exkmp();
        ans=0;
        for(int i=0;i<lt;i++)
            ans=(ans+(1+ex[i])*ex[i]/2)%mod;
        printf("%lld\n",ans);

    }
}

 

posted on 2017-08-21 15:01  Yxter  阅读(374)  评论(0编辑  收藏  举报

导航