hdu 6106 Classes

          Classes

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 290    Accepted Submission(s): 187

Problem Description
The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.
Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.
Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.
However, due to statistical errors, some data are wrong and these data should be ignored.
Smart you must know how to write a program to find the maximum number of students.
 
Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer N, indicates the number of class.
Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 
It's guaranteed that at least one data is right in each test case.

Limits
T100
1N100
0a,b,c,d,e,f,g100
 
Output
For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.
 
Sample Input
2
2
4 5 4 4 3 2 2
5 3 1 2 0 0 0
2
0 4 10 2 3 4 9
6 12 6 3 5 3 2

Sample Output
7
15
 
Hint
In the second test case, the data uploaded by Class 1 is wrong. Because we can't find a solution which satisfies the limitation. As for Class 2, we can calculate the number of students who only enrolled in course A is 2, the number of students who only enrolled in course B is 6, and nobody enrolled in course C, the number of students who only enrolled in courses A and B is 1, the number of students who only enrolled in courses B and C is 3, the number of students who only enrolled in courses A and C is 1, the number of students who enrolled in all courses is 2, so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  6107 6106 6105 6104 6103 
 
 
 
 
题意:
学校设立了三门选修课程,假设这些课程是A,B,C。N个班的学生参加了这些课程。
现在,学校想计算每班入读至少一门课程的学生人数,并记录最多学生人数。
每班上传7份资料,在每班中,选课程A的学生人数,选课程B的学生人数,选课程C的学生人数,选课程AB的学生人数,选课程BC的学生人数,选课程AC的学生人数,选课程ABC的学生人数。根据这7个数据,学校可以计算这个班级的学生人数。
现在给你n个班的数据,有些班的数据是错误的,我们应判断出来并忽视它,在剩下数据对的班级里,利用给出的7组数据,求出班级人数,输出班级最多的人数

题解:判断条件不充裕导致wa,最后三个条件容易忽视

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<cmath>
#include<cstring>
#include<bits/stdc++.h>

using namespace std;
int t,n,a,b,c,ab,bc,ac,abc;
int ans;

int main()
{
    scanf("%d",&t);
    for(;t>0;t--)
    {
       scanf("%d",&n);
       ans=0;
       for(int i=1;i<=n;i++)
       {
           scanf("%d%d%d%d%d%d%d",&a,&b,&c,&ab,&bc,&ac,&abc);
           if( ab<=a && ab<=b && bc<=b && bc<=c && ac<=a && ac<=c &&
              abc<=ab && abc<=ac && abc<=bc
               && ab+ac-abc<=a && bc+ac-abc<=c && ab+bc-abc<=b)
           {
               ans=max(ans,a+b+c-ab-bc-ac+abc);
           }
       }
       printf("%d\n",ans);
    }
    return 0;
}

 

posted on 2017-08-11 09:25  Yxter  阅读(116)  评论(0编辑  收藏  举报

导航