HDU 2669 Romantic (扩展欧几里得定理)

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6643    Accepted Submission(s): 2772


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

 

Sample Input
77 51
10 44
34 79
 
Sample Output
2 -3
sorry
7 -3

 

 
注意:求 a*x+b*y=1 中的x和y,给定a和b。
     (答案中的x不能是负数)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;

#define ll long long
ll n,m;

ll ex_gcd(ll a,ll b,ll &x,ll &y)
{
    if (b==0)
    {
        x=1; y=0;
        return a;
    }
    ll r=ex_gcd(b,a%b,y,x);
    y-=a/b*x;
    return r;
}
/*
ll ex_gcd(ll a,ll b,ll &x,ll &y)
{
    if(!b)
    {
        x=1,y=0;
        return a;
    }
    ll d=ex_gcd(b,a%b,x,y);
    ll x1=x;
    x=y;
    y=x1-(a/b)*y;
    return d;
}*/   //这段也是可以的
int main()
{
    while(~scanf("%lld%lld",&n,&m))
    {
        ll x,y;
        ll gcd=ex_gcd(n,m,x,y);
        if (gcd!=1){ printf("sorry\n"); continue;}
         else
         {
             while(x<0) x+=m;
             y=(1-n*x)/m;
             printf("%lld %lld\n",x,y);
         }

    }

    return 0;
}

 

posted on 2017-07-18 11:04  Yxter  阅读(202)  评论(0编辑  收藏  举报

导航