hdu 1728 逃离迷宫 (BFS)

逃离迷宫

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 44   Accepted Submission(s) : 23

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input

  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。

Output

  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input

2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3

Sample Output

no
yes
#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,m,sx,sy,tx,ty,i,k,t;
char mp[105][105];
int vis[105][105];
int dr[4][2]={{1,0},{0,1},{-1,0},{0,-1} };
struct node
{
    int x,y,k;
};

int check(int x,int y)
{
    if (x>=0 && x<n && y>=0 && y<m) return 1;
      else return 0;
}
int bfs()
{
   node p;
   queue<node> s;
   p.x=sx;
   p.y=sy;
   p.k=-1;
   s.push(p);
   vis[sx][sy]=1;
   while(!s.empty())
   {
       node q=s.front();
       s.pop();
       for(int i=0;i<4;i++)
       {
           int xx=q.x+dr[i][0];
           int yy=q.y+dr[i][1];
           while(mp[xx][yy]!='*' && check(xx,yy))
           {
               p.x=xx;
               p.y=yy;
               p.k=q.k+1;
               if (!vis[xx][yy])
               {
                   s.push(p);
                   vis[xx][yy]=1;
               }
               if (xx==tx && yy==ty)
                if (p.k<=k)return 1;
                   else return 0;
               xx=xx+dr[i][0];
               yy=yy+dr[i][1];

           }
       }
   }
   return 0;
}
int main()
{
    scanf("%d",&t);
    for(;t>0;t--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
            scanf("%s",&mp[i]);
        scanf("%d%d%d%d%d",&k,&sy,&sx,&ty,&tx);
        sy--; sx--; ty--; tx--;
        memset(vis,0,sizeof(vis));
        if(bfs())printf("yes\n");
                else printf("no\n");
    }
    return 0;
}

 

posted on 2016-07-14 08:47  Yxter  阅读(155)  评论(0编辑  收藏  举报

导航