poj 2104 K-th Number(主席树

 

Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 59058   Accepted: 20529
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion
主席树板子题
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 100001;
int ls[N*20],rs[N*20],sum[N*20];
int n,m,a[N],hash[N],cnt,root[N];
int x,y,k;
void lsh()
{
    sort(hash+1,hash+n+1);
    cnt=unique(hash+1,hash+n+1)-(hash+1);
    for(int i=1;i<=n;i++)a[i]=lower_bound(hash+1,hash+cnt+1,a[i])-hash;
}
int tot=0;
void build(int l,int r,int &rt,int pre,int w)
{
    rt=++tot;
    sum[rt]=sum[pre]+1;
    if(l==r)return;
    int mid=(l+r)>>1;
    if(w<=mid)rs[rt]=rs[pre],build(l,mid,ls[rt],ls[pre],w);
    else ls[rt]=ls[pre],build(mid+1,r,rs[rt],rs[pre],w);
}
int query(int l,int r,int x,int y,int k)
{
    if(l==r)return l;
    int mid=l+r>>1,tmp=sum[ls[y]]-sum[ls[x]];
    if(tmp>=k)return query(l,mid,ls[x],ls[y],k);
    else return query(mid+1,r,rs[x],rs[y],k-tmp);
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)scanf("%d",a+i),hash[i]=a[i];
    lsh();
//    printf("%d\n",cnt);for(int i=1;i<=cnt;i++) printf("%d ",hash[i]);
    for(int i=1;i<=n;i++) build(1,cnt,root[i],root[i-1],a[i]);
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&x,&y,&k);
        printf("%d\n",hash[query(1,cnt,root[x-1],root[y],k)]);
    }
    return 0;
}

 

posted @ 2017-08-10 21:46  zzzzx  阅读(145)  评论(0编辑  收藏  举报