[ACM] hdu 2025查找最大元素(水题)

Problem Description

对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。

Input

输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。

Output

对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。

Sample Input

abcdefgfedcba
xxxxx

Sample Output

abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

Author

lcy

Source

C语言程序设计练习(四)

 

代码:

#include <iostream>
#include <string>
using namespace std;

int main()
{
    string s;
    while(cin>>s)
    {
        char max=s[0];
        for(int i=1;i<s.length();i++)
            if(max<s[i])
            max=s[i];//max代表最大元素
        for(int i=0;i<s.length();i++)
        {
            cout<<s[i];
            if(s[i]==max)//遍历字符串,遇到最大元素时
                cout<<"(max)";
        }
        cout<<endl;
    }
    return 0;
}


 

posted @ 2014-02-24 15:56  同学少年  阅读(507)  评论(0编辑  收藏  举报