Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
 
/*
判断负权回路
加开一个数组
use[]
*/
#include <cstdio>
#include <cstdlib>
#include <cstring>
struct node
{
       int x,y,n;
}e[10000];
int k[1000];
int d[1000];
bool v[1000];
int f[10000000];
int use[1000];
int tot;
int F;
int N,M,W;
void add(int a,int b,int c)
{
     e[++tot].x=b;
     e[tot].y=c;
     e[tot].n=k[a];
     k[a]=tot;
}
bool SPFA(int start)
{
     int head=0,tail=1;
     f[tail]=start;
     d[start]=0;
     v[start]=true;
     while (head<tail)
     {
           int x=f[++head];
           v[x]=false;
           int t=k[x];
           while (t)
           {
                 if (d[e[t].x]>(d[x]+e[t].y))
                 {
                                           d[e[t].x]=d[x]+e[t].y;
                                           if (!v[e[t].x])
                                           {
                                                          f[++tail]=e[t].x;
                                                          v[e[t].x]=true;
                                                          use[e[t].x]++;
                                                          if (use[e[t].x]>N)
                                                          {
                                                                            return true;
                                                          }
                                           }
                 }
                 t=e[t].n;
           }
     }
     return false;
}
int main()
{
    scanf("%d\n",&F);
    for (int i=1;i<=F;i++)
    {
        tot=0;
        memset(v,0,sizeof(v));
        memset(e,0,sizeof(e));
        memset(k,0,sizeof(k));
        memset(d,63,sizeof(d));
        memset(use,0,sizeof(use));
        scanf("%d %d %d\n",&N,&M,&W);
        for (int j=1;j<=M;j++)
        {
            int a,b,c;
            scanf("%d %d %d\n",&a,&b,&c);
            add(a,b,c);
            add(b,a,c);
        }
        for (int j=1;j<=W;j++)
        {
            int a,b,c;
            scanf("%d %d %d\n",&a,&b,&c);
            add(a,b,-c);
        }
        bool ans=false;
        for (int j=1;j<=N;j++)
        {
            if (d[j]>1000000)
            {
                             if (SPFA(j))
                             {
                                        ans=true;
                                        break;
                             }
            }
        }
        if (ans) printf("YES\n");else printf("NO\n");
    }
}