Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
#include<iostream>
#include<cstdlib>
//#include<fstream>
using namespace std;
//ifstream cin("poj.txt");
//ofstream cout("poj.out");
struct node
{
       int num;
       char a[55];
}dna[110];
int n,m;
int cal(char *s,int n)
{
    int i,tot=0;
    int a[4]={0};
    for (i=n-1;i>=0;i--)
    {
        switch(s[i])
        {
                    case 'A':
                         a[1]++;
                         a[2]++;
                         a[3]++;
                         break;
                    case 'C':
                         a[2]++;
                         a[3]++;
                         tot+=a[1];
                         break;
                    case 'G':
                         a[3]++;
                         tot+=a[2];
                         break;
                    case 'T':
                         tot+=a[3];
        }
    }
    return tot;
}
int cmp(const void *a,const void *b)
{
    return (*(node *)a).num-(*(node *)b).num;
}
int main()
{
    int i;
    cin>>n>>m;
    for (i=0;i<m;i++)
    {
        cin>>dna[i].a;
        dna[i].num=cal(dna[i].a,n);
    }
    qsort(dna,m,sizeof(node),cmp);
    for (i=0;i<m;i++) cout<<dna[i].a<<endl;
    return 0;
}