HDU3336Count the string

HDU3336Count the string

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

 

Sample Input
1 4 abab
 

 

Sample Output
6
 

 

Author
foreverlin@HNU
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1711 1686 3746 1358 3341 
 
 
#include<cstdio>
#include<cstring>
#define mod 10007

using namespace std;

int T,l,next[200101],ans,num[200101];
char s[200101];

int main() {
    scanf("%d",&T);
    while(T--) {
        memset(num,0,sizeof(num));
        memset(next,0,sizeof(next));
        scanf("%d",&l);
        scanf("%s",s);
        ans=0;
        for(int i=1,j=0; i<l; i++) {
            while(j&&s[i]!=s[j]) j=next[j];
            if(s[i]==s[j]) ++j;
            next[i+1]=j;
        }
        for(int i=1; i<=l; i++) {
            num[i]+=(num[next[i]]+1)%mod;
            ans=(ans+num[i])%mod;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2018-09-01 15:35  清风我已逝  阅读(90)  评论(0编辑  收藏  举报