BZOJ 2038 2009国家集训队 小z的袜子(house)

2038: [2009国家集训队]小Z的袜子(hose)

Time Limit: 20 Sec  Memory Limit: 259 MB
Submit: 12464  Solved: 5592
[Submit][Status][Discuss]

Description

作为一个生活散漫的人,小Z每天早上都要耗费很久从一堆五颜六色的袜子中找出一双来穿。终于有一天,小Z再也无法忍受这恼人的找袜子过程,于是他决定听天由命……
具体来说,小Z把这N只袜子从1到N编号,然后从编号L到R(L 尽管小Z并不在意两只袜子是不是完整的一双,甚至不在意两只袜子是否一左一右,他却很在意袜子的颜色,毕竟穿两只不同色的袜子会很尴尬。
你的任务便是告诉小Z,他有多大的概率抽到两只颜色相同的袜子。当然,小Z希望这个概率尽量高,所以他可能会询问多个(L,R)以方便自己选择。

Input

输入文件第一行包含两个正整数N和M。N为袜子的数量,M为小Z所提的询问的数量。接下来一行包含N个正整数Ci,其中Ci表示第i只袜子的颜色,相同的颜色用相同的数字表示。再接下来M行,每行两个正整数L,R表示一个询问。

Output

包含M行,对于每个询问在一行中输出分数A/B表示从该询问的区间[L,R]中随机抽出两只袜子颜色相同的概率。若该概率为0则输出0/1,否则输出的A/B必须为最简分数。(详见样例)

Sample Input

6 4
1 2 3 3 3 2
2 6
1 3
3 5
1 6

Sample Output

2/5
0/1
1/1
4/15
【样例解释】
询问1:共C(5,2)=10种可能,其中抽出两个2有1种可能,抽出两个3有3种可能,概率为(1+3)/10=4/10=2/5。
询问2:共C(3,2)=3种可能,无法抽到颜色相同的袜子,概率为0/3=0/1。
询问3:共C(3,2)=3种可能,均为抽出两个3,概率为3/3=1/1。
注:上述C(a, b)表示组合数,组合数C(a, b)等价于在a个不同的物品中选取b个的选取方案数。
【数据规模和约定】
30%的数据中 N,M ≤ 5000;
60%的数据中 N,M ≤ 25000;
100%的数据中 N,M ≤ 50000,1 ≤ L < R ≤ N,Ci ≤ N。

HINT

Source

版权所有者:莫涛

用莫队离线去算,最后GCD处理一下即可,注意输出要用printf("%lld",ans);

题库不会让你TLE而是wa掉

#include <bits/stdc++.h>
using namespace std;
inline int read()
{
 int x=0;int f=1;char ch=getchar();
 while(!isdigit(ch)) {if(ch=='0') f=-1;ch=getchar();}
 while(isdigit(ch)) {x=x*10+ch-'0';ch=getchar();}
return x*f; 
}
inline long long gcd(long long x,long long y){
    while(y){
       long long t=y;y=x%y;x=t;
    }
    return x;
}
int a[100010];
int block;
int st;
int en;
long long int stort[100100];
int cut[100100];
long long int stor[100100];
long long int ans=0;
struct node
{
 int l;
 int r;
 int id;
}Q[100010];
inline bool mycmp(const node &a,const node &b){
 return a.l<b.l;
}
inline bool mycmpp(const node &a,const node &b){
 return a.r<b.r;
}
inline void move(node A){
 while(st<A.l) {cut[a[st]]--;ans-=cut[a[st]];st++;}
 while(st>A.l) {st--;ans+=cut[a[st]];cut[a[st]]++;}
 while(en<A.r) {en++;ans+=cut[a[en]];cut[a[en]]++;}
 while(en>A.r) {cut[a[en]]--;ans-=cut[a[en]];en--;}
}
int main(){
 int n;
 int m;
 cin>>n>>m;
 for(int i=1;i<=n;i++){
  a[i]=read();
 }
 for(int i=0;i<m;i++){
  Q[i].l=read();
  Q[i].r=read();
  Q[i].id=i;
 }
 sort(Q,Q+m,mycmp);
 block=(int)ceil(sqrt(1.0*m));
 st=en=1;cut[a[1]]++;
 for(int i=0;i<m;i+=block){
  if(i+block>m) sort(Q+1,Q+m,mycmpp);
  else sort(Q+i,Q+i+block,mycmpp);
 }
 for(int i=0;i<m;i++){
  move(Q[i]);
  stort[Q[i].id]=ans<<1;
  stor[Q[i].id]=1LL*(Q[i].r-Q[i].l)*(Q[i].r-Q[i].l+1);
  if(!stort[Q[i].id]||!stor[Q[i].id])  {stort[Q[i].id]=0;stor[Q[i].id]=1;}
  else{
   int GCD=gcd(stort[Q[i].id],stor[Q[i].id]);
   if(GCD!=1) {stort[Q[i].id]/=GCD;stor[Q[i].id]/=GCD;}
  }
 }
 for(int i=0;i<m;i++){
  printf("%lld/%lld\n",stort[i],stor[i]);
 }
 return 0;
}

  

 

posted @ 2017-12-23 08:26  zhangenming  阅读(127)  评论(0编辑  收藏  举报