All in All

    You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

    Given two strings and t , you have to decide whether s  is a subsequence of t , i.e. if you can remove

characters from t  such that the concatenation of the remaining characters is s .

 

Input

    The input contains several testcases. Each is specied by two strings s , t  of alphanumeric ASCII

characters separated by whitespace. Input is terminated by EOF .

 

Output

    For each test case output, if s is a subsequence of t .

 

Sample Input

sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

 

Sample Output

Yes

No

Yes

No

#include <iostream>
using namespace std;
char s[100000],t[100000];
int p,q;
int main() {
    while (scanf("%s%s",s,t)==2) {
        p=0;
        q=0;
        while (s[p]!='\0'&&t[q]!='\0') {
            if (t[q]==s[p]) p++;
            q++;
        }
        if (s[p]=='\0') printf("Yes\n");
        else printf("No\n");
    }
}

 

posted @ 2018-01-21 11:50  soildom  阅读(309)  评论(0编辑  收藏  举报