Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2601    Accepted Submission(s): 723


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

 

Sample Input
1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.
 

 

Sample Output
7
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1175 1072 1180 1026 1983 
这题做的爽, 关键是题目信息有意思。 不太明白的是为什么非得用三维数组加一个状态才能过, 用判断是不是石头和步数是否可以整除K, 再把路标记成石头不能过, 也真是奇葩。 
 
#include <queue> 
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
char map[101][101]; int vis[101][101][10], ac[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};
struct Maze{
    int x, y, step;
} R, M, B;
int n, m, k;
int Bfs(int a, int b){
    memset(vis, 0, sizeof(vis));
    queue<Maze> Q;
    R.x = a; R.y = b; R.step = 0;
//    map[a][b] = '#';
    Q.push(R);
    while(!Q.empty()){
        R = Q.front(); Q.pop();
        for(int i = 0; i < 4; i++){
            M.x = R.x + ac[i][0];
            M.y = R.y + ac[i][1];
            M.step = R.step + 1;
            int d = M.step%k;
            if(M.x >= 0 && M.x < n && M.y >= 0 && M.y < m && !vis[M.x][M.y][d]){ //(map[M.x][M.y] != '#' ||(map[M.x][M.y] == '#' && M.step%k == 0))){
                if(map[M.x][M.y] == 'G')
                    return M.step;
                else{
                    vis[M.x][M.y][d] = 1; 
                    if(map[M.x][M.y] == '#' && d)
                        continue;
                    Q.push(M); 
                    
                } 
            }
        }
    }
    return 0;
}
int main(){
    int T;
    scanf("%d", &T);
    while(T--){
        scanf("%d%d%d", &n, &m, &k);
        int x, y;
        for(int i = 0; i < n; i++){
            scanf("%s", map[i]);
            for(int j = 0; j < m; j++)
                if(map[i][j] == 'Y'){
                    x = i; y = j;    
                }
        }
        int ans = Bfs(x, y);
        if(ans)
            printf("%d\n", ans);        
        else
            printf("Please give me another chance!\n");
    }
    return 0;
} 

 

posted on 2015-11-01 12:00  cleverbiger  阅读(248)  评论(0编辑  收藏  举报