L2-003 月饼 (25 分)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

坑点是输入的库存和单价都有浮点数 无语了
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include <stdio.h>
#include <iostream>
#include <cstring>
#include <vector>
#include <queue>
#include <sstream>
#include <algorithm>
int N, D;
const int si = 1010;
using namespace std;
struct node {
    double v;
    int id;
    bool operator < (const node x)const {
        return v > x.v;
    }
}no[si];
 
double totprice[si];
double store[si];
int main() {
    cin >> N >> D;
    for (int i = 0; i < N; i++)
        cin >> store[i];
    for (int i = 0; i < N; i++)
        cin >> totprice[i];
    for (int i = 0; i < N; i++) {
        no[i].id = i;
        no[i].v = totprice[i] * 1.0 / store[i];
    }
    sort(no, no + N);
    int cnt = 0, crt = 0;
    double ans = 0.0;
     
    while (cnt < D && crt < N) {
        int id = no[crt].id;
        while (store[id]-- && cnt < D) {
            ans += no[crt].v;
            cnt++;
        }
        crt++;
    }
    printf("%.2f\n", ans);
    return 0;
}