Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 68562   Accepted: 23869

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

 

 

用的LIS的做法 参考1458

字符串s长度为N 将输入的字符串倒过来记做rs 则N - (s与rs的最长公共子序列的长度) 就是答案

用scanf或者getchar()都是1600MS 不知道0MS的是怎么做的

 

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>
const int si = 5016;
using namespace std;
char s[si], rs[si];
int dp[2][si];
int main() {
    int N;
    cin >> N;
    scanf("%s", s);
    for (int i = 0; i < N; i++) rs[N - i - 1] = s[i];
    int e = 0;
    for (int i = 1; i <= N; i++) {
        for (int j = 1; j <= N; j++) {
            dp[e][j] = max(dp[1 - e][j], dp[e][j - 1]);
            if (s[i - 1] == rs[j - 1]) {
                dp[e][j] = max(dp[e][j], dp[1 - e][j - 1] + 1);
            }
        }
        e = 1 - e;
    }
    cout << N - dp[1 - e][N];
    return 0;
}