【排序专题】实践2-众数

众数

Description

众数是指在一组数据中,出现次数最多的数。例如:1, 1, 3 中出现次数最多的数为 1,则众数为 1。

给定一组数,你能求出众数吗?

Input

输入数据有2行

第一行输入N(1~3万)

第2行n个数表示排序的数(可重复)(小于100)

Output

最大的

Sample Input 1 

12

1 2 3 4 5 5 6 7 8 9 10 11 12

Sample Output 1

5 2
      我的思路

N大数小使用木桶排序查看次数

   


      我的代码

   

  Lauguage

  C++

    Code

 

#include <bits/stdc++.h>
using namespace std;
int a[101];
int main()
{
    int n;
    cin>>n;
    int i;
    for(i=1;i<=n;i++){
    	int x;
    	cin>>x;
    	a[x]++;
	}
	int max=0;
	for(i=0;i<=100;i++)if(a[i]>max)max=a[i];
	for(i=0;i<=100;i++)if(a[i]==max)cout<<i<<" "<<max<<endl;
    
}


   



BYE~


posted @ 2018-05-17 19:27  SMALLff  阅读(225)  评论(0编辑  收藏  举报