POJ 3252 Round Numbers 数学题解

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6


整体来说,十分困难的一道数学counting problem。

利用组合数学去做这些题目总是须要很费力去总结规律的。

或许是数学思维还须要多锻炼吧。

详细是找出规律,依照二进制数位去数这种题目。当然是不能模拟的。


#include <iostream>
#include <stdio.h>
#include <vector>
#include <algorithm>
#include <functional>
#include <bitset>
using namespace std;

int cTbl[33][33];

int calCombinate(int up, int down)
{
	down = min(down, up - down);
	int ans = 1;
	for (int i = 1; i <= down; i++)
	{
		ans *= (up - i + 1);
		ans /= i;
	}
	return ans;
}

void genTbl()
{
	cTbl[0][0] = 1;
	for (int i = 1; i < 33; i++)
	{
		cTbl[i][0] = 1;
		for (int j = 1; j <= i; j++)
		{
			cTbl[i][j] = calCombinate(i, j);
		}
	}
}

int calZeros(int n)
{
	bitset<33> bn = n;
	int len = 32;
	while (!bn[len]) len--;

	int ans = 0;
	for (int i = 1; i < len; i++)
	{
		for (int j = (i+2)>>1; j <= i; j++)
			ans += cTbl[i][j];
	}
	int zeros = 0, half = (len+2) >> 1;
	for (int i = len-1; i >= 0; i--)
	{
		if (bn[i])//前面选择好01了。改为为1。变为0。然后选择余下的0有多少个
		{
			for (int j = half-zeros-1; j <= i; j++)
			{
				if (j < 0) continue;
				ans += cTbl[i][j];
			}
		}
		else zeros++;
	}
	return ans;
}

int main()
{
	genTbl();
	int a, b;
	while (scanf("%d %d", &a, &b) != EOF)
	{
		printf("%d\n", calZeros(b+1) - calZeros(a));
	}
	return 0;
}



posted on 2017-05-06 13:00  slgkaifa  阅读(186)  评论(0编辑  收藏  举报

导航