poj 2955 Brackets

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1734 Accepted: 869

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

Stanford Local 2004


题意:类似于最长公共子序列的最大匹配括号数
思路:明显就是一种自底向上型DP,一开始自己还以为自己套lrj书上的思路,后来才发现两者间的不同,之间差别就是此题需要把子结构都遍历一次,本来想看看有什么更快的,开始找到的都更这个差不多思路
 

   状态转移方程:if(mach(i,j))f[i][j]=f[i+1][j-1]+1;
                  f[i][j]=max(f[i][j],f[i][i+g]+f[i+g+1][j])《0<=g<k》
#include <stdio.h>
#include <string.h>
int f[110][110];
char s[110];
int max(int a,int b){return a>b?a:b;}
int mach(int a,int b){if((s[a]=='['&&s[b]==']')||(s[a]=='('&&s[b]==')'))return 1;return 0;}
int main()
{
    int i,j,k,len,g;
    while(scanf("%s",s)&&s[0]!='e')
    {
        memset(f,0,sizeof(f));
        len=strlen(s);
        for(i=0;i<len;i++){
            f[i][i]=0;
            if(mach(i,i+1))f[i][i+1]=1;
        }
        for(k=2;k<len;k++)
              for(i=0;i<len-k;i++)
              {
                  j=i+k;
                  if(mach(i,j))f[i][j]=f[i+1][j-1]+1;
                  for(g=0;g<k;g++)
                     f[i][j]=max(f[i][j],f[i][i+g]+f[i+g+1][j]);
              }
        printf("%d\n",f[0][len-1]*2);
    }
    return 0;
}

posted on 2011-07-21 12:06  sleeper_qp  阅读(359)  评论(0编辑  收藏  举报

导航