Similar Word 变序词代码

Similar Word

description

  It was a crummy day for Lur. He failed to pass to the CET-6 (College English Test Band-6). Looking back on how it was in last year gone by, he gradually noticed he had fled too many English Lessons. But he determines to memorize words on his bed ,not in the classroom. You know, it is not that easy to pass the test mainly because the large amount of born words.

     Lur is intelligent on games , never English. He cann't learn the similar words by heart. He

always choose to select a word to learn from the similar words . For him, two words are similar if and only if one word can equal to the other by multiple cyclic shift(at least 1). For example, "car" and "arc" are similar words, while "car" and "rca" are also similar words . To save more time to play games,

  Lur want to know wether two words are similar words faster, he asks you to write a program to tell him ,can you help him ?

                                                    

input

  There are multiple test cases. Each case contains two lines. Each line contains a word,

W. You can assume that length(W)<=10^5 . Ended by EOF.

                                                    

output

  Output “yes” in a single line if two words are similar,otherwise you should output  “no” in a single line.

                                                    

sample_input

car

arc

car

cra

car

car

                                                    

sample_output

yes

no

no

 

 

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
 
//Copyright      感谢Coral提供法思路
 
int main()
{        chars1[100001], s2[100001], temp[200002];
         int  len,len2, i;
 
         while( cin >> s1 >> s2 )
         {        if ( strcmp ( s1, s2 ) != 0 ) //长的一样可不行
                   {        len = strlen ( s1 ); len2= strlen(s2);
                            {        strcpy ( temp, s1 ); //复制组成循环单词
 
                                     for( i = len; i < 2 * len - 1; i++ )
                                     {        temp[i] = s1[i - len];
                                     }
 
                                     //cout<< temp << endl;
                                     if( strstr ( temp, s2 )&& len==len2 ) //查找是否存在该单词序列strstr不能保证单词构成相同,比如car和ca;
                                               cout<< "yes" << endl;
 
                                     else
                                               cout<< "no" << endl;
 
                            }
                   }
 
                   else
                            cout<< "no" << endl;
 
         }
 
 
}



 

posted @   一杯半盏  阅读(154)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
· 【自荐】一款简洁、开源的在线白板工具 Drawnix
· 园子的第一款AI主题卫衣上架——"HELLO! HOW CAN I ASSIST YOU TODAY
· Docker 太简单,K8s 太复杂?w7panel 让容器管理更轻松!
点击右上角即可分享
微信分享提示