3.8——K-th Substring

题目描述

You are given a string s. Among the different substrings of s, print the K-th lexicographically smallest one.
A substring of s is a string obtained by taking out a non-empty contiguous part in s. For example, if s = ababc, a, bab and ababc are substrings of s, while ac, z and an empty string are not. Also, we say that substrings are different when they are different as strings.
Let X=x1x2…xn and Y=y1y2…ym be two distinct strings. X is lexicographically larger than Y if and only if Y is a prefix of X or xj>yj where j is the smallest integer such that xj≠yj.

Constraints
1 ≤ |s| ≤ 5000
s consists of lowercase English letters.
1 ≤ K ≤ 5
s has at least K different substrings.
Partial Score
200 points will be awarded as a partial score for passing the test set satisfying |s| ≤ 50.

 

输入

Input is given from Standard Input in the following format:
s
K

 

输出

Print the K-th lexicographically smallest substring of K.

 

样例输入

复制样例数据

aba
4

样例输出

b

 

提示

s has five substrings: a, b, ab, ba and aba. Among them, we should print the fourth smallest one, b. Note that we do not count a twice.

 

来源/分类

ABC097&ARC097 

意思就是找字串,求出第k大的。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <set>
using namespace std;

set<string> p;
int main ()
{
    string s;
    int k;
    cin>>s>>k;
    int i,j;
    int n=s.size();
    for (i=0;i<=n-1;i++)
        for (j=1;j<=5;j++)
        {
            if (i+j-1>=n) continue;
            p.insert(s.substr(i,j));
        }
    for (i=1;i<=k-1;i++)
    {
        p.erase(p.begin());
    }
    cout<<(*(p.begin()))<<endl;//这样使用
    return 0;
}

 

posted on   湫叶  阅读(116)  评论(0)    收藏  举报

编辑推荐:
· MySQL下200GB大表备份,利用传输表空间解决停服发版表备份问题
· 记一次 .NET某固高运动卡测试 卡慢分析
· 微服务架构学习与思考:微服务拆分的原则
· 记一次 .NET某云HIS系统 CPU爆高分析
· 如果单表数据量大,只能考虑分库分表吗?
阅读排行:
· 7 个最近很火的开源项目「GitHub 热点速览」
· DeepSeekV3:写代码很强了
· 记一次 .NET某固高运动卡测试 卡慢分析
· Visual Studio 2022 v17.13新版发布:强化稳定性和安全,助力 .NET 开发提
· MySQL下200GB大表备份,利用传输表空间解决停服发版表备份问题
< 2025年4月 >
30 31 1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 1 2 3
4 5 6 7 8 9 10

导航

统计

点击右上角即可分享
微信分享提示