HDU 1052田忌赛马 Tian Ji -- The Horse Racing


Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30034    Accepted Submission(s): 9045


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
200 0 0
 

 题目的意思  :  现在已经不是 3 只马比赛 而是n只 马  赢一场的200元 输一场  -200元 问最大得多少钱


思路:

本着一个目的,赚的最多;   有本事赢,就赢, 没本事赢 就去 干掉对方最牛B的  换取最大利润

1: 最牛B的先比较, 能力强就干掉他, 能力弱 ,先不干掉, 让最菜的去消耗掉他

2: 两个最菜的比较; 能力强 就把他干掉,  如果不行就去把最牛B的干掉;

3: 能力差不多;(贪心了,  )能力一样, 干掉的话都转不着便宜,要是 能为全体做出贡献,那就 牺牲吧(我不入地狱谁入地狱) O(∩_∩)O哈哈~



#include <iostream>
#include <algorithm>
#include <stack>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <cstring>
#include <cmath>
#include <string>

typedef long long ll;

using namespace std;

ll a[10100];
ll b[10100];
int cmp(int a,int b)
{
    return a<b;
}
int main()
{
    int n,i,j,sum;
    int k=200;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
            scanf("%lld",&a[i]);
        for(i=0;i<n;i++)
            scanf("%lld",&b[i]);
        sort(b,b+n,cmp);
        sort(a,a+n,cmp);
//        for(i=0;i<n;i++)
//        {
//            printf("%lld %lld\n",a[i],b[i]);
//        }
        sum=0;k=200;
        int s1,s2;
        s1=s2=n-1;
        i=j=0;
        int z=0;
        for(;z<n;z++)
        {
            if(a[s1]>b[s2])//最牛比较
            {
                sum+=k;
                s1--;s2--;
            }
            else if(a[i]>b[j])//最垃圾比较
            {
                sum+=k;
                i++;j++;
            }
            else if(a[i]<b[j])//最垃圾干最牛
            {
                sum-=k;
                i++;
                s2--;
            }
            else if(a[i]==b[j])
            {
                if(a[i]<b[s2])
                {
                    sum-=k;
                    i++;s2--;
                }
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}




posted @ 2017-05-17 13:17  Sizaif  阅读(149)  评论(0编辑  收藏  举报