HDU 1009 FatMouse' Trade (贪心)


FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77129    Accepted Submission(s): 26485


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500
 

思路  : 按照  交换性价比来排序:  当大于时 按 100%   小于时  性价比乘以 剩下数量


#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>

using namespace std;

typedef long long ll;

struct node{
    double f,j,p;
}s[10010];
int cmp(node a,node b)
{
    return a.p>b.p;
}
int main()
{
    int i,m,n;
    while(~scanf("%d %d",&m,&n))
    {
        if(m==-1&&n==-1)
            break;
        double sum=0,res=m;
        for(i=0;i<n;i++)
        {
            cin>>s[i].j>>s[i].f;
            s[i].p=s[i].j/s[i].f;
        }
        sort(s,s+n,cmp);
//        for(i=0;i<n;i++)
//        {
//            printf("%lf %lf %lf\n",s[i].j,s[i].f,s[i].p);
//        }
        for(i=0;i<n;i++)
        {
            if(res>s[i].f)
            {
                sum+=s[i].j;
                res-=s[i].f;
            }
            else
            {
                sum+=res*s[i].p;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}


123

posted @ 2017-05-19 18:02  Sizaif  阅读(153)  评论(0编辑  收藏  举报