HDU 1049 Climbing Worm (简单贪心)

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19479    Accepted Submission(s): 13246


Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

Sample Input
10 2 1 20 3 1 0 0 0
 

Sample Output
17 19
 

专业水题30年 

 上升一秒走u   休息一秒下降d    最简单的 

 

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>

using namespace std;

int main()
{
     int n,m,d,i;
     while(~scanf("%d %d %d",&n,&m,&d),n!=0&&m!=0&&d!=0)
     {

         int sum=0;
         i=0;
        while(sum<=n)
        {
            sum+=m;
            i++;
            if(sum>=n)
                break;
            sum-=d;
            i++;
            if(sum>=n)
                break;
        }
         cout<<i<<endl;
     }
    return 0;
}


posted @ 2017-05-19 18:06  Sizaif  阅读(172)  评论(0编辑  收藏  举报