POJ 1328 Radar Installation (贪心)


Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 87083   Accepted: 19500

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


题目大意:   

x 轴上 分布雷达,   在 轴周围 有许多的点, 这些点是小岛,   问  最少需要多少个雷达,可以把 这些 岛屿覆盖,   如果,  岛屿 距离x轴的距离 超过 雷达半径 则输出-1   ;


刚开始 ,我的思路是 通过 贪心雷达的 位置 来 扫描,   包括点, 一次一次的  移动距离,  后来发现 并不能用,  

 正解是  通过岛屿,做雷达半径的圆, 与x 轴 交 两个 点  left 和 right     分别比较  岛屿的 left  和right  来  获得 雷达数目,  如果没有交叉 则需要雷达,  有交叉不需要;


#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cmath>
#include <queue>
#include <string>

typedef long long ll;
const int MAXN=1300;

using namespace std;

struct node{
    double l;
    double r;
}a[MAXN],b[MAXN],k;

int cmp(node a,node b)
{
    if(a.l==b.l)
        return a.r>b.r;
    return a.l<b.l;
}
int main()
{
    int n,i,j;
    double d;
    int cont=1;
    while(scanf("%d %lf",&n,&d),n!=0&&d!=0)
    {
        int flag=0;
        for(i=0;i<n;i++)// b[i]  l-->x  r-->y
        {
            cin>>b[i].l>>b[i].r;
            if(fabs(b[i].r)>d)
                flag=1;
        }
        if(flag||d<0)
        {
            printf("Case %d: -1\n",cont++);
            continue;
        }
        sort(b,b+n,cmp);
        for(i=0;i<n;i++)
        {
            a[i].l=b[i].l*1.0-sqrt(d*d-b[i].r*b[i].r);
            a[i].r=b[i].l*1.0+sqrt(d*d-b[i].r*b[i].r);
        }
         k=a[0];int sum=1;//

        for(i=1;i<n;i++)
        {
            if(a[i].l>k.r)//右大于左 无公共区域
            {
                sum++;
                k=a[i];
            }
            else if(a[i].r<k.r)
            {
                k=a[i];
            }
        }
        printf("Case %d: %d\n",cont++,sum);
    }
    return 0;
}


13

posted @ 2017-05-29 15:40  Sizaif  阅读(142)  评论(0编辑  收藏  举报