UVA 10801 By ACReaper

Problem ?
Lift Hopping
Time Limit: 1 second

Ted the bellhop: "I'm coming up and if there isn't
a dead body by the time I get there, I'll make one
myself. You!"
Robert Rodriguez, "Four Rooms."

A skyscraper has no more than 100 floors, numbered from 0 to 99. It has n (1<=n<=5) elevators which travel up and down at (possibly) different speeds. For each i in {1, 2,... n}, elevator number i takes Ti(1<=Ti<=100) seconds to travel between any two adjacent floors (going up or down). Elevators do not necessarily stop at every floor. What's worse, not every floor is necessarily accessible by an elevator.

You are on floor 0 and would like to get to floor k as quickly as possible. Assume that you do not need to wait to board the first elevator you step into and (for simplicity) the operation of switching an elevator on some floor always takes exactly a minute. Of course, both elevators have to stop at that floor. You are forbiden from using the staircase. No one else is in the elevator with you, so you don't have to stop if you don't want to. Calculate the minimum number of seconds required to get from floor 0 to floor k (passing floor k while inside an elevator that does not stop there does not count as "getting to floor k").

Input
The input will consist of a number of test cases. Each test case will begin with two numbers, n and k, on a line. The next line will contain the numbers T1T2,... Tn. Finally, the next n lines will contain sorted lists of integers - the first line will list the floors visited by elevator number 1, the next one will list the floors visited by elevator number 2, etc.

Output

For each test case, output one number on a line by itself - the minimum number of seconds required to get to floor k from floor 0. If it is impossible to do, print "IMPOSSIBLE" instead.

Sample Input Sample Output
2 30
10 5
0 1 3 5 7 9 11 13 15 20 99
4 13 15 19 20 25 30
2 30
10 1
0 5 10 12 14 20 25 30
2 4 6 8 10 12 14 22 25 28 29
3 50
10 50 100
0 10 30 40
0 20 30
0 20 50
1 1
2
0 2 4 6 8 10
275
285
3920
IMPOSSIBLE

Explanation of examples

In the first example, take elevator 1 to floor 13 (130 seconds), wait 60 seconds to switch to elevator 2 and ride it to floor 30 (85 seconds) for a total of 275 seconds.

In the second example, take elevator 1 to floor 10, switch to elevator 2 and ride it until floor 25. There, switch back to elevator 1 and get off at the 30'th floor. The total time is 
10*10 + 60 + 15*1 + 60 + 5*10 = 285 seconds.

In example 3, take elevator 1 to floor 30, then elevator 2 to floor 20 and then elevator 3 to floor 50.

In the last example, the one elevator does not stop at floor 1.


Problemsetter: Igor Naverniouk

Alternate solutions: Stefan Pochmann, Frank Pok Man Chu



分析:这个题目很好,首先让我复习了Dijkstra算法,其次在学会了读入处理时的技巧,再者最重要的就是图模型的建立,思路简单的话,建立起来,实现起来就十分方便,但是要想到却没那么容易!该题目是这样的,只要两个楼层能相互到达(能停下)我们就在这两个顶点间连接一条边,这就是建图的过程。我觉得这才是关键,其它都是浮云。


代码如下:

#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
const int maxn = 6;
const int N = 106;
const int INF = 0x3fffffff;
int T[maxn];
int w[N][N],d[N],arr[N];
typedef pair<int,int> pii;
priority_queue<pii,vector<pii>,greater<pii> > q; 
void Read_D(int n){//对于这种比较特殊的输入,自己编写读写函数进行读写 
	for(int i = 0; i < N; i++){
		for(int j = 0; j < N; j++){
			w[i][j] = i == j?0:INF;
		}
	}
	for(int i = 1; i <= n; i++)
		scanf("%d",&T[i]);
	for(int i = 1; i <= n; i++){
		int pos = 1;
		do{
			scanf("%d",&arr[pos++]);
		}while(getchar() != '\n');//读完一行数据
		for(int j = 1; j < pos; j++){
			for(int k = j; k < pos; k++){
				int tmp = abs(arr[j] - arr[k])*T[i];
				if(w[arr[j]][arr[k]] > tmp)
					w[arr[k]][arr[j]] = w[arr[j]][arr[k]] = tmp;
			}
		} 
		
	}
}
void Dijkstra(int src){
	for(int i = 0;i < N; i++)//Init Single
		d[i] = INF;
	d[src] = 0;
	q.push(make_pair(d[src],src));
	while(!q.empty()){
		pii u = q.top();q.pop();
		int x = u.second;
		if(u.first != d[x]) continue;
		for(int v = 0; v < N; v++){
			if(x == 0){
				if(d[v] > d[x] + w[x][v]){
					d[v] = d[x] + w[x][v];
					q.push(make_pair(d[v],v));
				}
			}else{
				if(d[v] > d[x] + w[x][v] + 60){
					d[v] = d[x] + w[x][v] + 60;
					q.push(make_pair(d[v],v));
				}
			}
		}	
	} 	
}
int main(){
	int n,k;
	while(scanf("%d%d",&n,&k) != EOF){
		Read_D(n);
		Dijkstra(0);
		if(d[k] < INF)
			printf("%d\n",d[k]);
		else
			puts("IMPOSSIBLE");
	}
	return 0;
}


这段代码参考了别人的,但最后是自己按照这思路完全自己写出,还是有搜获!加油!
2013 05 15

By ACReaper

posted @ 2013-05-15 22:13  算法黑魔王  阅读(155)  评论(0编辑  收藏  举报