1702: 拯救行动

 

题目描述

公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。
给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。

输入

第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入
1、两个整数代表N和M, (N, M <= 200).
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#"代表墙壁。

输出

如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible"

样例输入

2
7 8
#@#####@
#@a#@@r@
#@@#x@@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@ 
13 40
@x@@##x@#x@x#xxxx##@#x@x@@#x#@#x#@@x@#@x
xx###x@x#@@##xx@@@#@x@@#x@xxx@@#x@#x@@x@
#@x#@x#x#@@##@@x#@xx#xxx@@x##@@@#@x@@x@x
@##x@@@x#xx#@@#xxxx#@@x@x@#@x@@@x@#@#x@#
@#xxxxx##@@x##x@xxx@@#x@x####@@@x#x##@#@
#xxx#@#x##xxxx@@#xx@@@x@xxx#@#xxx@x#####
#x@xxxx#@x@@@@##@x#xx#xxx@#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#xx@##@#@##xx@#@@x@x
x#x#@x@#x#@##@xrx@x#xxxx@##x##xx#@#x@xx@
#x@@#@###x##x@x#@@#@@x@x@@xx@@@@##@@x@@x
x#xx@x###@xxx#@#x#@@###@#@##@x#@x@#@@#@@
#@#x@x#x#x###@x@@xxx####x@x##@x####xx#@x
#x#@x#x######@@#x@#xxxx#xx@@@#xx#x#####@

样例输出 

13
7
代码:

#include<bits/stdc++.h>
using namespace std;
const int MAXN = 200 + 1;
const int INF = 0x3f3f3f3f;
const int dx[4] = {1, -1, 0, 0}, dy[4] = {0, 0, 1, -1};
int S, n, m;
int vis[MAXN][MAXN];
struct Pos{
int x, y, step;
bool operator > (const Pos &o) const {
return step > o.step;
}
}s, e;
priority_queue<Pos, vector<Pos>, greater<Pos> > q;
bool bfs(int x, int y) {
q.push((Pos){x, y, 1});
vis[x][y] = INF;
while(!q.empty()) {
Pos ext = q.top();
q.pop();
for(int i=0; i<4; ++i) {
int xx = ext.x + dx[i], yy = ext.y + dy[i];
if(vis[xx][yy]!=INF && xx>0 && xx<=n && yy>0 && yy<=m) {
q.push((Pos){xx, yy, ext.step+vis[xx][yy]});
vis[xx][yy] = INF;
if(xx==e.x && yy==e.y) {
printf("%d\n", q.top().step);
return 1;
}
}
}
}
return 0;
}
int main() {
scanf("%d", &S);
while(S--) {
char ch;
memset(vis, 0, sizeof(vis));
while(!q.empty()) q.pop();
scanf("%d%d", &n, &m);
ch = getchar();
for(int i=1; i<=n; ++i) {
for(int j=1; j<=m; ++j) {
ch = getchar();
if(ch == '#') vis[i][j] = INF;
if(ch == 'x') vis[i][j] = 2;
if(ch == 'a') e.x = i, e.y = j;
if(ch == 'r') s.x = i, s.y = j;
if(ch == '@') vis[i][j] = 1;
}
ch = getchar();
}
bool fl = bfs(s.x, s.y);
if(!fl) puts("Impossible");
}
}

 
posted @ 2022-04-02 22:27  吴杰锋  阅读(106)  评论(0编辑  收藏  举报