Try Again

HDU 2988 Dark roads(kruskal模板题)

Dark roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1067    Accepted Submission(s): 474


Problem Description
Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

 

 

Input
The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 231.
 

 

Output
For each test case print one line containing the maximum daily amount the government can save.
 

 

Sample Input
7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0
 

 

Sample Output
51
原来每条路上的灯都亮,太浪费,现在只保持一条通路,问可以节省多少
因为数据量太大,因此可用kruskal算法
#include <iostream> 
#include <algorithm> 
#include <cstring> 
#include <cstdio>
#include <vector> 
#include <queue> 
#include <cstdlib> 
#include <iomanip>
#include <cmath> 
#include <ctime> 
#include <map> 
#include <set> 
using namespace std; 
#define lowbit(x) (x&(-x)) 
#define max(x,y) (x>y?x:y) 
#define min(x,y) (x<y?x:y) 
#define MAX 100000000000000000 
#define MOD 1000000007
#define pi acos(-1.0) 
#define ei exp(1) 
#define PI 3.141592653589793238462
#define ios() ios::sync_with_stdio(false)
#define INF 0x3f3f3f3f 
#define mem(a) (memset(a,0,sizeof(a))) 
typedef long long ll;
int f[2000006];
int n,m;
struct Node
{
    int u;
    int v;
    int w;
    friend bool operator<(const Node &a,const Node &b)
    {
        return a.w<b.w;
    }
}e[2000006];
int find(int x)
{
    return f[x]==x?x:find(f[x]);
}
int kruskal()
{
    int sum=0;int k=n;
    for(int i=0;i<m;i++)
    {
        int u=find(e[i].u);
        int v=find(e[i].v);
        if(u!=v)
        {
            sum+=e[i].w;
            if(u<v) f[u]=v;
            else f[v]=u;
            if(--k==1) break;
        }
    }
    return sum;
}
int main()
{
    while(scanf("%d%d",&n,&m)&& (n && m))
    {
        for(int i=0;i<=n;i++)
        {
            f[i]=i;
        }
        int ans=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
            ans+=e[i].w;
        }
        sort(e,e+m);
        printf("%d\n",ans-kruskal());
    }
    return 0;
}

 

posted @ 2017-08-03 11:07  十年换你一句好久不见  阅读(218)  评论(0编辑  收藏  举报