1058 A+B in Hogwarts (20 分)
1058 A+B in Hogwarts (20 分)
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut
(Galleon
is an integer in [0,107], Sickle
is an integer in [0, 17), and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
思路
代码
1.测试点2错误,原因大概在于计算过程中发生了溢出,尝试使用long long
#include<stdio.h>
const int Galleon = 17 * 29;
const int Sickle = 29;
int main(){
int g1, s1, k1;
int g2, s2, k2;
scanf("%d.%d.%d %d.%d.%d", &g1, &s1, &k1, &g2, &s2, &k2);
long long a = g1 * Galleon + s1 * Sickle + k1;
long long b = g2 * Galleon + s2 * Sickle + k2;
long long sum = a + b;
if(sum == 0) printf("0");
else printf("%d.%d.%d", sum / Galleon, sum % Galleon /Sickle, sum % Galleon % Sickle);
return 0;
}
#include<stdio.h>
const int Galleon = 17 * 29;
const int Sickle = 29;
int main(){
long long g1, s1, k1;
long long g2, s2, k2;
scanf("%lld.%lld.%lld %lld.%lld.%lld", &g1, &s1, &k1, &g2, &s2, &k2);
long long a = g1 * Galleon + s1 * Sickle + k1;
long long b = g2 * Galleon + s2 * Sickle + k2;
long long sum = a + b;
printf("%lld.%lld.%lld", sum / Galleon, sum % Galleon /Sickle, sum % Galleon % Sickle);
return 0;
}