A1042 Shuffling Machine (20 分)
1042 Shuffling Machine (20 分)
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:
S1, S2, ..., S13,
H1, H2, ..., H13,
C1, C2, ..., C13,
D1, D2, ..., D13,
J1, J2
where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13
题意
有54张牌,编号为1~54,初始按编号从小到大排列。另外,这些牌按初始排列给定花色,即从左至右分别为13张S、13张H、13张C、13张D、2张J,如下所示:S1, S2,..., S13, H1, H2,..., H13, C1, C2,..., C13, D1,D2,..., D13,J1,J2,
接下来执行一-种操作, 这种操作将牌的位置改变为指定位置。例如有5张牌S3, H5, C1,D13, J2,然后给定操作序列{4,2,5,3,1},因此把S3放到4号位、把H5放到2号位、C1放到5号位、D13 放到3号位、J2 放到1号位,于是就变成了J2, H5, D13, S3, C1。
现在需要将这种操作执行K次,求最后的排列结果。例如上面的例子中,如果执行第二次操作,那么序列J2, H5, DI3, S3, C1就会变成C1, H5, S3, J2, D13.
思路
步骤1:由于题目给出的操作直接明确了每个位置上的牌在操作后的位置,因此不妨设置两个数组start[]与end[],分别用来存放执行操作前的牌序与执行操作后的牌序(即start[i]表示操作前第i个位置的牌的编号)。
这样在每一次操 作中就可以把数组star[]中的每一个位置的牌号存放到数组end[]的对应转换位置中,然后用数组end[]覆盖数组start[]来给下一次操作使用。这样当执行K轮操作后,数组start]中即存放了最终的牌序。
步骤2:由于输出需要用花色表示,且每种花色有13张牌,因此不妨使用char型数组[mp]= {S, H, C, D, J}来建立编号与花色的关系。例如,假设当前牌号为x,那么mp[(x-1)/13]即为这张牌对应的花色(即1 ~ 13号为'S',14~26号为'H等),而(x- 1)%13+ 1即为它在所属花色下的编号。
注意点
①最好在纸上自己推导一下编号和花色的对应关系,特别要注意牌的编号减1的原因。
②注意输出格式的控制,不允许在一行的末尾多出空格,否则会返回“格式错误”。
参考代码
#include<stdio.h>
const int N = 54;
char mp[5] = {'S', 'H', 'C', 'D', 'J'};//牌的编号与花色的对应关系
int start[N+1], end[N+1], next[N+1];//next数组存放每个位置上的牌在操作后的位置
int main(){
int K;
scanf("%d", &K);
for(int i = 1; i <= N; i++){
start[i] = i;//初始化牌的编号
}
for(int i = 1; i <= N; i++){
scanf("%d", &next[i]);//输入每个位置上的牌在操作后的位置
}
for(int step = 0; step < K; step++){//执行K次操作
for(int i = 1; i <= N; i++){
end[next[i]] = start[i];//把第i个位置的牌的编号存于位置next[i]
}
for(int i = 1; i <= N; i++){
start[i] = end[i];//把end数组赋值给start数组以供下次操作使用
}
}
for(int i = 1; i <= N; i++){
if(i != 1) printf(" ");//控制输出格式
start[i]--;//把牌的编号减一
printf("%c%d", mp[start[i]/13], start[i] % 13 + 1);
}
return 0;
}