HDU 2602 Bone Collector (简单01背包)

Bone Collector

http://acm.hdu.edu.cn/showproblem.php?pid=2602

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 

 

Sample Output
14
 

解题代码:

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <iostream>
using namespace std;

const int max_v = 1004;
int dp[max_v];
struct boot
{
    int val, cost;    
};

int main()
{
    int T;
    scanf ("%d", &T);
    int N, V;
    boot B[max_v];
    while (T--)
    {
        memset (dp, 0, sizeof (dp));
        scanf ("%d%d", &N, &V);
        for (int i = 1; i <= N; i ++)
            scanf ("%d", &B[i].val);
        for (int i = 1; i <= N; i ++)
            scanf ("%d", &B[i].cost);
        for (int i = 1; i <= N; i ++)
        {
            for (int v = V; v >= B[i].cost; v --)
                dp[v] = max(dp[v], dp[v-B[i].cost] + B[i].val);            
        }
        printf ("%d\n", dp[V]);
    }
    return 0;
}

 

posted on 2013-07-17 15:08  圣手摘星  阅读(155)  评论(0编辑  收藏  举报

导航