TOJ-1117 Game Prediction

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.

Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.


Input

The input consists of several test cases. The first line of each case contains two integers m (2 ≤ m ≤ 20) and n (1 ≤ n ≤ 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.


Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.


Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0


Sample Output

Case 1: 2
Case 2: 4



Source: China 2002 - Beijing

 

很水的题。用样例的第二组举例,所有牌中最大的是6*11=66,我们有66,则必定能赢一局。我们从66递减遍历所有牌,

遍历到i表示假设当前场上剩余的牌最大是i,那么如果这张牌在我们手中,我们这一局就赢了,否则就输了。我们做如下遍历:

66 win++;65 win++;64 win--;63 win++;62 win++;61 win++;60 win--;...

其实遍历到61时的win值就是答案。可以这样理解,当场上最大为64时,我们把63打出去了(因为要求至少赢几轮,我们就得这样做。。。)

win先减后加保持不变,就表示了我们能保证赢的轮数在计算时未受影响,但是如果win连续减的次数比加多,结果受到了影响,

因此我们要将win的最大值存下来作为答案。这算是类似贪心的一个过程。

#include <iostream>
#include <stdlib.h>
#include <memory.h>
using namespace std;
bool a[10010];
int main()
{
    int n,m,i,c=0,x;
    while(cin>>n>>m && n!=0 && m!=0)
    {
        memset(a,0,sizeof(bool)*10010);
        for(i=0;i<m;i++)
        {
            cin>>x;
            a[x]=1;
        }
        int win=0,lwin=0;
        for(i=m*n;i>0;i--)
        {
            if(a[i])
            {
                win++;
                if(win>lwin)
                    lwin=win;
            }
            else
                win--;
        }
        cout<<"Case "<<++c<<": "<<lwin<<endl;
    }
    return 0;
}

 

posted @ 2017-01-19 12:14  DGSX  阅读(154)  评论(0编辑  收藏  举报