hdu1024 Max Sum Plus Plus[降维优化好题(貌似以后可以不用单调队列了)]

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28136    Accepted Submission(s): 9810


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

 

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

 

Author
JGShining(极光炫影)
 

 

 

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int N=1e6+5;
int n,m,a[N];
//int f[N][N];
int f[N],maxn[N];
int main(){
    while(~scanf("%d%d",&m,&n)){
        memset(f,0,sizeof f);
        memset(maxn,0,sizeof maxn);
        for(int i=1;i<=n;i++) scanf("%d",a+i);
        /*for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                f[i][j]=f[i-1][j]+a[i];
                for(int k=1;k<i;k++){
                    f[i][j]=max(f[i][j],f[k][j-1]+a[i]);
                }
            }
        }
        printf("%d\n",f[n][m]);*/
        int nowans=0;
        for(int j=1;j<=m;j++){
            nowans=-1e9;
            for(int i=j;i<=n;i++){
                f[i]=max(f[i-1],maxn[i-1])+a[i];
                maxn[i-1]=nowans;
                nowans=max(nowans,f[i]);
            }
        }
        printf("%d\n",nowans);
    }
    return 0;
}

 

posted @ 2017-04-14 15:28  神犇(shenben)  阅读(905)  评论(0编辑  收藏  举报