poj 1458 Common Subsequence

Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 46387   Accepted: 19045

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

 
就是求最长公共子序列
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
#define N 1010
char x[N],y[N];
short int f[N][N];
int main(){
    while(scanf("%s%s",x+1,y+1)==2){
        int lx=strlen(x+1),ly=strlen(y+1);
        for(int i=1;i<=lx;i++)
            for(int j=1;j<=ly;j++)
                if(x[i]==y[j])
                    f[i][j]=f[i-1][j-1]+1;
                else
                    f[i][j]=max(f[i-1][j],f[i][j-1]);
        printf("%d\n",f[lx][ly]);
        for(int i=0;i<=lx;i++)for(int j=0;j<=ly;j++)f[i][j]=0;        
    }
    return 0;
}

 

posted @ 2016-05-15 17:19  神犇(shenben)  阅读(317)  评论(0编辑  收藏  举报