POJ 1915 Knight Moves
Knight Moves
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 29822 | Accepted: 14013 |
Description
Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
Input
The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
For each scenario of the input you have to calculate the minimal amount of
knight moves which are necessary to move from the starting point to the
ending point. If starting point and ending point are equal,distance is zero.
The distance must be written on a single line.
Sample Input
3 8 0 0 7 0 100 0 0 30 50 10 1 1 1 1
Sample Output
5 28 0
Source
TUD Programming Contest 2001, Darmstadt, Germany
【题意】
给你n个数,然后求它们两两相减的绝对值,然后找出这些绝对值的中位数
给你一张n*n的棋盘,给你两个坐标。问一只“马”从一点到另一点的最少步数。(“马”是8个方向都可以走的)
【分析】
(类似走迷宫)BFS遍历最短路
【代码】
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=305;
int dx[9]={0,1,1,-1,-1,2,2,-2,-2};
int dy[9]={0,2,-2,2,-2,1,-1,1,-1};
int n,cas,dis[N][N];bool vis[N][N];
int sx,sy,ex,ey;
struct data{
int x,y,s;
data(int _x=0,int _y=0,int _s=0){
x=_x;y=_y;s=_s;
}
};
inline void Clear(){
memset(vis,0,sizeof vis);
memset(dis,0x3f,sizeof dis);
}
inline int bfs(){
if(sx==ex&&sy==ey) return 0;
queue<data>q;
q.push(data(sx,sy,0));
dis[sx][sy]=0;vis[sx][sy]=1;
while(!q.empty()){
data now=q.front();q.pop();
for(int i=1;i<=8;i++){
int nx=now.x+dx[i];
int ny=now.y+dy[i];
int ns=now.s+1;
if(nx<1||ny<1||nx>n||ny>n||vis[nx][ny]) continue;
vis[nx][ny]=1;
if(nx==ex&&ny==ey) return ns;
dis[nx][ny]=ns;
q.push(data(nx,ny,ns));
}
}
}
inline void Init(){
scanf("%d%d%d%d%d",&n,&sx,&sy,&ex,&ey);
sx++;sy++;ex++;ey++;
}
inline void Solve(){
printf("%d\n",bfs());
}
int main(){
for(scanf("%d",&cas);cas--;){
Clear();
Init();
Solve();
}
return 0;
}