HDU 1867 A + B for you again(kmp)

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8904    Accepted Submission(s): 2159


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
asdf sdfg asdf ghjk
 

Sample Output
asdfg asdfghjk
 

Author
Wang Ye
 

Source
 

Recommend
lcy
 
题意:

给你两个字符串a ,b,在输出要求下输出a+b或者b+a。先说一下这个‘+“法的规定。若a的某一最大后缀和b的某一最大前缀相等,则可合并。例:abcdef+defppp=abcdefppp。

输出要求,a+b和b+a中长度较短的字符串。若两个字符串长度相等,则输出字典序较小的。

做法:kmp分别求:a+b时a的后缀和b的前缀的最大相同序列。

                                    b+a时b的后缀和a的前缀的最大相同序列。

然后输出选相同序列的较大者输出。

若相等,则再比较a和b的字典序,再输出。


代码:

#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <cstdio>
#include <vector>
#include <iomanip>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define ll long long
#define mod 1000000007
#define mem(a) memset(a,0,sizeof(a))

using namespace std;

const int maxn = 100000 + 5 , inf = 0x3f3f3f3f;

int Next[maxn];
char str1[maxn],str2[maxn];
void cal_next(char *a){
    memset(Next,-1,sizeof(Next));
    int len = strlen(a);
    Next[0] = -1;
    int k = -1 ;
    for(int p = 1 ; p < len ; p ++ ){
        while(k>-1&&a[k+1]!=a[p]) k = Next[k];
        if(a[k+1]==a[p])
            Next[p]=++k;
    }
}
int kmp(char *s,char *a){
    cal_next(a);
    int slen = strlen(s);
    int alen = strlen(a);
    int k = -1;
    int i = 0;
    for(; i < slen ; i++ ){
        while(k>-1&&s[i]!=a[k+1]) k = Next[k];
        if(a[k+1]==s[i]) k++;
    }
    if(i==slen){
//        cout<<i<<" "<<k<<endl;
        return k;
    }
    return -1;
}
void solve(){
    int x = kmp(str1,str2);
    int y = kmp(str2,str1);
    if(x>y){
        printf("%s",str1);
        printf("%s\n",str2+x+1);
    }
    else if(x<y){
        printf("%s",str2);
        printf("%s\n",str1+y+1);
    }
    else{
        if(strcmp(str1,str2)<0){
            printf("%s",str1);
            printf("%s\n",str2+x+1);
        }
        else{
            printf("%s",str2);
            printf("%s\n",str1+y+1);
        }
    }
}
int main(){
//    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    while(scanf("%s %s",str1,str2)!=EOF) solve();
    return 0 ;
}

posted @ 2018-04-26 11:11  dslybyme7  阅读(113)  评论(0编辑  收藏  举报