Stones_优先队列

Stones

TimeLimit: 5000/3000 MS (Java/Others)  MemoryLimit: 65535/32768 K (Java/Others)
64-bit integer IO format:%I64d
Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it. 
Output
Just output one line for one test case, as described in the Description. 
SampleInput
2
2
1 5
2 4
2
1 5
6 6
SampleOutput
11
12

题意是, 捡石头。 第 i 块石头, i 为奇数时, 捡的位置加上扔的位置, 放在前面, 偶数不管, 求最远的石头。( 就是最后的石头)
用一块石头,
ceode:
#include <cstdio>
#include <queue>
#include <algorithm>
#include <vector>
using namespace std;
typedef struct _node node;
struct _node
{
    int spot;
    int len;

    friend bool operator > ( node _elemta, node _elemtb ){
        if( _elemta.spot == _elemtb.spot ){
            return _elemta.len > _elemtb.len;
        }
        return _elemta.spot > _elemtb.spot;
    }
};

void solve( int );

int main(void)
{
    //freopen( "e://test.txt", "r", stdin );
    int t, n;
    while( scanf( "%d", &t ) != EOF ){
        while( t -- ){
            scanf( "%d", &n );
            solve( n );
        }
    }
    return 0;
}

void solve( int _n )
{
    priority_queue < node, vector< node >, greater < node > > que;
    node tmp;
    for( int i=1; i <= _n; ++ i ){
        scanf( "%d%d", &tmp.spot, &tmp.len );
        que.push( tmp );
    }

    for( int i=1; que.size(); ++ i ){
        tmp = que.top();
        que.pop();
        if( i&1 ){
            tmp.spot += tmp.len;
            que.push( tmp );
        }
    }

    printf( "%d\n", tmp.spot );
}
View Code

 

posted @ 2016-04-08 19:07  假大空  阅读(168)  评论(0编辑  收藏  举报