Black Box_双优先队列

Black Box

TimeLimit: 1000ms  MemoryLimit:10000KB
64-bit integer IO format:%lld
Problem Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 

N Transaction i Black Box contents after transaction Answer
(elements are arranged by non-descending)
1 ADD(3) 0 3
2 GET 1 3 3
3 ADD(1) 1 1, 3
4 GET 2 1, 3 3
5 ADD(-4) 2 -4, 1, 3
6 ADD(2) 2 -4, 1, 2, 3
7 ADD(8) 2 -4, 1, 2, 3, 8
8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8
9 GET 3 -1000, -4, 1, 2, 3, 8 1
10 GET 4 -1000, -4, 1, 2, 3, 8 2
11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


 
Input
Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
 
Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
 
SampleInput
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
SampleOutput
3
3
1
2

搞两个优先队列, 分别为 最大堆 和 最小堆, 目的是 在 n 个 数里, 获得第几大数。
code:
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
void solve( int, int );

int main(void)
{
    //freopen( "d://test.txt", "rw+", stdin );
    int n, t;
    while( scanf( "%d%d", &n, &t ) != EOF ){
        solve( n, t );
    }
    return 0;
}

void solve( int n, int t )
{
    int *_m = new int [ n+1 ];
    int num;
    priority_queue < int, vector< int >, greater <int> > pri_min;
    priority_queue < int, vector< int >, less <int> > pri_max;
    for( int i=0; i < n; ++ i ){
        scanf( "%d", _m+i );
    }

    for( int i=1, j=0; t --; ++ i ){
        scanf( "%d", &num );
        // 快速 填充到指定数目的数
        while( pri_max.size()+pri_min.size() < num ){
            pri_min.push( _m[ j ++ ] );
        }
        // 快速 填充 到最大堆, 使最大堆数目为 i
        while( pri_max.size() < i ){
            pri_max.push( pri_min.top() );
            pri_min.pop();
        }
        // 交换 最大堆 和 最小堆 数据, 直到符合情况
        while( pri_min.size() && pri_max.top() > pri_min.top() ){
            num = pri_max.top();
            pri_max.pop();
            pri_max.push( pri_min.top() );
            pri_min.pop();
            pri_min.push( num );
        }
        printf( "%d\n", pri_max.top() );
    }

    delete [] _m;
}
View Code

 

posted @ 2016-04-08 19:01  假大空  阅读(199)  评论(0编辑  收藏  举报