Joseph(循环链表)

Joseph(循环链表)

TimeLimit:1000MS  MemoryLimit:32768KB
64-bit integer IO format:%I64d
Problem Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14. 
Output
The output file will consist of separate lines containing m corresponding to k in the input file. 
SampleInput
3
4
0
SampleOutput
5
30


该题算是 约瑟夫 问题的所有扩展了。
code:
// 该题算是 约瑟夫 问题的全部理解了。

#include <cstdio>
using namespace std;
const int all = 15;
int ans[ all ];
int calc( int n, int m, int p );
// oj有用 压力测试, 打个表查找吧
int main(void)
{
    int n, tmp;
    while( scanf( "%d", &n ) != EOF && n != 0 ){
        if( ans[n] ){
            printf( "%d\n", ans[n] );
            continue;
        }

        ans[n] = n+1;
        for( int i=1; i <= n; ++ i ){
            tmp = calc( 2*n, ans[n], i );
            if( tmp <= n ){
                i = 0;
                ++ ans[n];
            }
        }
        printf( "%d\n", ans[n] );
    }
    return 0;
}


// 该函数计算第 p 个 跳 m 个数的 数, 返回该数
int calc( int n, int m, int p )
{
    int f = 0 ;
    for( int i=n-p+1; i <= n; ++ i )
    {
        f = (f+m-1)%i+1;
    }
    return f;
}
View Code

 

posted @ 2016-03-05 17:35  假大空  阅读(235)  评论(0编辑  收藏  举报