HDU1098——Ignatius's puzzle

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3518    Accepted Submission(s): 2319


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

 

Sample Input
11 100 9999
 

 

Sample Output
22 no 43
 

 

Author
eddy
------------------------------------------------------------------------------------------------------------------------------------------------------------------------
数学归纳法证明! 最后只要证明 18 + k * x 能整除65就可以了。
 
#include<stdio.h>

int main ()
{
int i = 0;
int k = 0;

while ( scanf ( "%d" , &k ) != EOF )
{
if ( k % 65 == 0 )
{
printf ( "no\n" ) ;
continue ;
}
for ( i = 1 ; i <= 65 ; ++ i )
{
if ( ( 18 + k * i ) % 65 == 0 )
{
printf ( "%d\n" , i ) ;
break ;
}
}
if ( i > 65 )
{
printf ( "no\n" ) ;
}
}
return 0 ;
}
 
posted @ 2012-04-06 20:59  1050768624  阅读(583)  评论(0编辑  收藏  举报