HDU1024——Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7919    Accepted Submission(s): 2624


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

 

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

 

Author
JGShining(极光炫影)
 
 
题意:给定一个数组,求其分成m个不相交子段和最大值的问题。
状态方程:方程 dp[i][j]=Max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j。
代码:
View Code
#include <stdio.h>
#include <string.h>
#define N 1000010
#define inf 9999999

int dp[N], pre[N], num[N], max;

int Max(int a, int b)
{
return a > b ? a : b;
}
int main()
{
int i, j;
int n, m;
while(scanf("%d%d", &m, &n) !=EOF)
{
for(i=1;i<=n;i++)
{
scanf("%d", num+i);
}
memset(dp, 0, sizeof(dp));
memset(pre, 0, sizeof(pre));
for(i=1;i<=m;i++)
{
max = -inf;
for(j=i;j<=n;j++)
{
dp[j] = Max(dp[j-1]+num[j], pre[j-1]+num[j]);
pre[j-1] = max;
if(max < dp[j])
{
max = dp[j];
}
}
}
printf("%d\n", max);
}
return 0;
}

posted @ 2011-12-22 20:14  1050768624  阅读(297)  评论(0编辑  收藏  举报